Problem, multi electrical under bonnet connectors - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 3Likes
  • 1 Post By Iceman47
  • 2 Post By lukew
 
Thread Tools
(Post Link) post #1 of 8 Old 4 Weeks Ago Thread Starter
Status: -
AO Member
 
Join Date: May 2019
County: -
Posts: 34
Problem, multi electrical under bonnet connectors

The 147 M Jet TJD 1.9 8V engine looking for the pressure sensor electrical plug to try and stick the box MOD in line. Problem, not 100% sure which one is pulled. I think it's the one at the back of the engine on the common rail, in the middle, although as said not 100%. an ass to get at one LOL. And for the life of me I cannot remove/ unplug the little swine, is there some magic process or method for it to slide off, cos I cannot budge it. Not without ripping half of the plastic plug to bits, NOT a good idea. Anyone help on this one ?
Iceman47 is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 8 Old 4 Weeks Ago Thread Starter
Status: -
AO Member
 
Join Date: May 2019
County: -
Posts: 34
Problem solved!
maxiboy wales likes this.
Iceman47 is offline  
(Post Link) post #3 of 8 Old 4 Weeks Ago
Status: -
Global Mod Team
 
paul.o's Avatar
 
Join Date: Dec 2008
Location: United Kingdom
County: Lancashire
Posts: 4,729

Member car:

Alfa GT 2.0JTS

Pleas tell, in case anybody else has the same problem.
paul.o is offline  
(Post Link) post #4 of 8 Old 4 Weeks Ago Thread Starter
Status: -
AO Member
 
Join Date: May 2019
County: -
Posts: 34
Quote:
Originally Posted by paul.o View Post
Pleas tell, in case anybody else has the same problem.
Just me being a dick again! The little connector classic, release method, press quite hard on the spring loaded clip button at the top, and pull a little out she comes. I obviously was not squeezing hard enough. Sounds rude LOL.
Iceman47 is offline  
(Post Link) post #5 of 8 Old 4 Weeks Ago
Status: -
AO Member
 
lukew's Avatar
 
Join Date: Aug 2017
County: -
Posts: 179
Quote:
Originally Posted by Iceman47 View Post
Just me being a dick again! The little connector classic, release method, press quite hard on the spring loaded clip button at the top, and pull a little out she comes. I obviously was not squeezing hard enough. Sounds rude LOL.
I've had a vew days of this with airbag connectors. No access and no way to see what needs to be poked, prodded and squoze.
maxiboy wales and Iceman47 like this.
lukew is offline  
(Post Link) post #6 of 8 Old 4 Weeks Ago Thread Starter
Status: -
AO Member
 
Join Date: May 2019
County: -
Posts: 34
Quote:
Originally Posted by lukew View Post
I've had a vew days of this with airbag connectors. No access and no way to see what needs to be poked, prodded and squoze.
I was the same, but I had a moment of enlightenment;LOL, I noticed the connectors, on the injector heaters were exactly the same type, but in a position to easy get at and see, so I experimented with one of those to unclip and reclip back on, SO I thought that's how you little swines go on and off. Try and look for visually the same type of clip in an area that's easy to get at. As I am more than sure, they tend to use the same sets of clips all over the place on these cars.
Iceman47 is offline  
(Post Link) post #7 of 8 Old 4 Weeks Ago
Status: -
AO Member
 
lukew's Avatar
 
Join Date: Aug 2017
County: -
Posts: 179
Quote:
Originally Posted by Iceman47 View Post
I was the same, but I had a moment of enlightenment;LOL, I noticed the connectors, on the injector heaters were exactly the same type, but in a position to easy get at and see, so I experimented with one of those to unclip and reclip back on, SO I thought that's how you little swines go on and off. Try and look for visually the same type of clip in an area that's easy to get at. As I am more than sure, they tend to use the same sets of clips all over the place on these cars.
Junior timer connectors I think they are, little steel clip you need to push up to release the damn thing.
lukew is offline  
(Post Link) post #8 of 8 Old 4 Weeks Ago Thread Starter
Status: -
AO Member
 
Join Date: May 2019
County: -
Posts: 34
Quote:
Originally Posted by lukew View Post
Junior timer connectors I think they are, little steel clip you need to push up to release the damn thing.
Umm not on this one, it's plastic fantastic, and we sqeeeez the tab and pull.
Iceman47 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
bonnet , connectors , electrical , multi , problem

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome