Alfa Romeo Forum - View Single Post - 147 GTA Progress thread
You are currently unregistered, register for more features.    
View Single Post
Chris155
Status: - Update
Guest
 
Posts: n/a
147 GTA Progress thread


Image1 by chris147gta, on Flickr


Image2 by chris147gta, on Flickr


Interior needs a going over with saddle soap;


IMG_7089 by chris147gta, on Flickr


IMG_7093 by chris147gta, on Flickr


IMG_7096 by chris147gta, on Flickr

Another reason to pull the cam covers off (oil leak) Or is it just from clumsy topping up? Meh.


IMG_7113 by chris147gta, on Flickr

The wheels are wearing 215's for some reason and juding by the receipts it has been for most of it's life. They're also looking very dull, as are the (305mm) brakes;


IMG_7099 by chris147gta, on Flickr


Shiney (post Dad's efforts) front wheel


IMG_7102 by chris147gta, on Flickr



The os front keeps rubbing against the liner. The non GTA lights and used to be silver front bumper suggest front end damage but I think this is just down to the wing suppor/leg being twisted out of shape because the bolt in the bottom siezed.


IMG_7108 by chris147gta, on FlickrThe other side is equally grubby;


IMG_7107 by chris147gta, on Flickr

The suggestion of a light front end is also evidenced by the headlights and the moisture in one of them. The front end is straight otherwise


IMG_7119 by chris147gta, on Flickr


Image5 by chris147gta, on Flickr


Image3 by chris147gta, on Flickr


IMG_7128 by chris147gta, on Flickr
 
 
 
For the best viewing experience please update your browser to Google Chrome