Alfa Romeo Forum - View Single Post - New giuliette, some issues
You are currently unregistered, register for more features.    
View Single Post
(Post Link) post #23 of Old 1 Week Ago
Isotope
Status: I wanted to stay in the EU
AO Silver Member
 
Join Date: Mar 2015
County: -
Posts: 1,166

Member car:

Guilietta

Quote:
Originally Posted by Anthos View Post
I did contact them and they were fairly willing to help. They said to take it to any garage I know to have a look and if it is something worse going on to let them (dealer) know and to take care of it. I ll take it to some ac specialists nearby me over the weekend and have them check the ac and have a look at the bluetooth as well. I live in Kettering by the way.

This is the "weird" wire.

I appreciate your advices.
I would take it back to the dealer you bought it from, if you use anyone else and inform them of it you may be waiving their obligation to supply something fit for purpose. The flashing mileage indicator will require more than disconnecting the battery to reset it. It will require some sort of software to perform a reset, and an EOBD scanner will not reset that as it can usually only clear MIL light errors. If you still have no joy from the dealer I might be able to help you next weekend as in 9 days away as I have the software to do the checks.

The weird wire? That is the exact same route my dashcam power supply goes so I think as others have already said it will probably end with a micro usb plug at some point near the mirror.
Isotope is offline  
 
 
For the best viewing experience please update your browser to Google Chrome