Alfa Romeo Forum - View Single Post - Solved-Spider roof fault
You are currently unregistered, register for more features.    
View Single Post
Ryan_The_Spider
Status: Leaning towards keeping the Spider
AO Member
 
Ryan_The_Spider's Avatar
 
Join Date: Jul 2011
Location: United Kingdom
County: Warwickshire
Posts: 627

Member car:

Giulia Veloce

Quote:
Originally Posted by yerbamateo View Post
Well itīs too cold today for a walk to the garage, to make a photo, but below is the schematics from eLearn, could be helpful. Sensor that might give the message right after closing is probably 23.

Sensors are easy to spot - black plastic thingy with cables, mounted on top of the hydraulic cylinders. They're flat, with QRcode on them, fixed to the cylinder through plastic holder that can be shifted up and down.

Hall sensors are very reliable, this is the same type of sensor that is used in ABS, so malfunction is rather due to bad positioning or cabling. One other thing to keep in mind - function of the sensors is redundant, i.e.. one bad signal does not necesarily mean interruption of the process, especially on hood closure.

The least reliable sensors in our hood must be the one in the flap motor - itīs a potentiometer, so susceptible to wear and moisture. This is my next weekend project - disassembly of the flap motors

//Mateo
Do you know the part numbers for those sensors for the lid? (Ideally all of them).

Ideally Alfa and supplier because I am sure the latter will be much cheaper. Hopefully they are just cheap microswitches which you buy from RS or something.

PM if it is easier.
Ryan_The_Spider is offline  
 
 
For the best viewing experience please update your browser to Google Chrome