need help!!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 27-12-07 Thread Starter
Status: -
AO Member
Join Date: Dec 2007
Posts: 14
need help!!!!


i have an alfa 147 sillyspeed that has just recently gone kaput. I am unable to select any of the gears either in manual or auto. This is the 2nd time it has happened and i have been advised that it could be an ECU or battery fault. I have removed the battery and reconnected, still not working, can any help me please. thank you xxxx
elaine2980 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Re: need help!!!!

Hi Elaine, welcome to AO check out our tech sections for more help and info on your 147's problem. Post up your questions in there and more people will see it and be able to help you. Alfa 147, 156 & 159 - Alfa Romeo Forum
classicgal93 is offline  
Status: -
AO Silver Member
garry-graig's Avatar
Join Date: Dec 2007
Location: Vatican City State (Holy
County: -
Posts: 3,419
Images: 4
Re: need help!!!!

garry-graig is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: need help!!!!

Hello and welcome
nigelread is offline  
Status: Zoe FTW
AO Rosso Alfa Member
baby278278's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Essex
Posts: 46,602
Images: 49
Re: need help!!!!

Hello and Welcome

Hope you had a good xmas
baby278278 is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: need help!!!!

Welcome onboard and good luck
BigFoot is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: need help!!!!

Hello and welcome to AO.
rammy is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

« Hello | Hello »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome