Hi guys - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 26-06-16 Thread Starter
Status: -
AO Member
33_Stradale's Avatar
Join Date: Jun 2016
County: Croatia
Posts: 13
Hi guys

I'm new to this forum as its not my first language but i see that you are a great group of people.
Not new to Alfa Romeo world. Now driving 156 and 166 both 2.0TS. This is my 7th and 8th Alfa's.
Sorry for posting a problem before introducing myself, i'm new to this stuff. :-)
33_Stradale is offline  
Sponsored Links
Status: Lots to do
Global Mod Team
paul.o's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: Lancashire
Posts: 3,790
Images: 58
Welcome to Alfaowner
paul.o is offline  
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,611
Images: 19
Welcome to AO
David P is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome :wave:
Durty dog is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome