Hi - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 20-06-16 Thread Starter
Status: -
Join Date: Jun 2016
County: -
Posts: 1

Hello Everyone, thanks for having me.

I've got a 2010 - 159 1.9JTDm 16v.

Had it a couple of years now, all seems to be going well so far. For those interested had it re-mapped to 200+ BHP with an EGR blank.

I've been looking at swirl flap issues, after much mucking about, it looks like mine doesn't have any.
Could this be the case? I you could point me to any photo's of what to look for, I'd be much obliged.
Grimble is offline  
Sponsored Links
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,658
Images: 20
Welcome to AO

Check out the Tech Lounge for advice, info & help Alfa 159, Brera & 946 Spider - Alfa Romeo Forum
David P is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome :wave:
Durty dog is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome