cooling problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 11 Old 17-12-07 Thread Starter
Status: -
Join Date: Dec 2007
Posts: 2

Member car:

Alfa 146 T.S.

cooling problem

Dear friend,

Hello to all, this is my first time in the forum, i have visited this forum many times but this is the first time to post a message.

my name is joseph i'm from Lebanon.

i have brought a new Alfa 146 twin spark, i like my car so much but no i am having some problem, especially cooling problem.

so i'm posting this message and hoping that someone could give me some tips to solve my problem (i can't find any mechanics specialist in alfa in my region).

problem :

some time i drive my car for a long trip to the mountain or in the city the cooling system seems to work fine, when the indicator show me the cooling degree on 80 the car reduce the temperature by it self so i have no problem with that, but other days using the same road, same waeather, the temperature keep going until i receive a red light so i had to stop and wait for couple hours .

i hope this was clear, please if someone have any ideas or tips to answer me..

thank you...
jmahfouz is offline  
Sponsored Links
Status: Back in V6-land!
AO Silver Member
Ronald's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: Kent
Posts: 3,336
Images: 30

Member car:

Not an Alfa

Re: cooling problem

Welcome to AO!

1) Does your fan operate properly?

2) Check that the thermostat is operating properly. When started from cold feel the top and bottom radiator hoses, if they gradually warm up the thermostat isn't functioning properly. The top hose in particular should remain cool until the engine reaches operating temperature and you will feel a sudden increase in heat from this hose as the 'stat opens up.

Let us know how you get on.

Ronald is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: cooling problem

Hello and Welcome !!

Post your questions here for a better reponse !!
nomad is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Re: cooling problem

Ciao e benvenuto
Enjoy the site!

(for greatest effect: Do as Nomes said!)
Al Faromeo is offline  
Status: Zoe FTW
AO Rosso Alfa Member
baby278278's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Essex
Posts: 46,602
Images: 49
Re: cooling problem

Hello and Welcome
baby278278 is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: cooling problem

welcome to AO

Do as the Nomadic one says
dpat is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: cooling problem

Hello and welcome to AO
rammy is offline  
Status: i don't use fuelly
AO Platinum Member
nigelread's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Essex
Posts: 22,304
Images: 5
Re: cooling problem

Hello and welcome
nigelread is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: cooling problem

Hi Joseph, hope you get your alfa sorted
classicgal93 is offline  
(Post Link) post #10 of 11 Old 18-12-07 Thread Starter
Status: -
Join Date: Dec 2007
Posts: 2

Member car:

Alfa 146 T.S.

Re: cooling problem

thank you..

i will try to check the Thermostat.
jmahfouz is offline  
Status: - Update
Posts: n/a
Re: cooling problem

hi and welcome to AO...

all the best


Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

cooling , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome