New member with an 89 Veloce - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

  • 1 Post By fidlers
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 27-03-16 Thread Starter
Status: -
Join Date: Mar 2016
Location: Redmond, Washington
County: US-
Posts: 4
New member with an 89 Veloce

Hello everyone. I have had a Red 89 Alfa Veloce since 89. I used to drive it to work downtown Seattle, but after 100K miles I decided to put it in the garage. I have been driving it about 4 or 5 times a year, but now that I am retired I decided to get a bit more use out it. It is in almost perfect shape and I love the car, however, for the first time, it won't start now. It just turns over without firing. I am going to check the spark with a tester, then the next thing is to try starting fluid, however, I am mystified about which hose to pull off the plenum and spray starting fluid. My next step is to post my problem in the right group.


SCGT likes this.
fidlers is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Welcome to AO Denny waving Check out the Classic Tech section for more help with your Spider. Cheers
classicgal93 is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome :wave:
Durty dog is offline  
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Welcome to Alfaowner 🤗

Join Alfabook Today
SCGT is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

member , veloce

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome