Hello & Help Please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 10 Old 30-09-07 Thread Starter
Status: -
PhilSharrocks's Avatar
Join Date: Sep 2007
Location: Nottingham
Posts: 3
Hello & Help Please

Just found the Forum - I have owned a 156 v6 sportwagon since new in 2000, loads of grief in the early days with misfires eventually tracked down to coils by dealer. Then 4 years problem free, I had cambelt changed at 56,000 and no issues until recently. I notice a flat spot at 4000 rpm when accelerating fairly hard, then a week ago the engine warning light came on. A local garage diagnosed Oxygen sensor fault and has replaced both sensors - I have just had the car out for first time and no warning lights but flat spot is still there intermittantly. Any ideas would be greatly appreciated.
PhilSharrocks is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Hello & Help Please

Sorry mate can't help. Try posting in the tech lounges.

Welcome to AO
BigFoot is offline  
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,061
Images: 2
Re: Hello & Help Please

HI glad to have you join us
classicgal93 is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: Hello & Help Please

Welcome to AO
dpat is offline  
Status: Standby.........
AO Platinum Member
mr.orange's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:


Re: Hello & Help Please

Hello and welcome
mr.orange is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Hello & Help Please

Hello and welcome to AO.
rammy is offline  
Status: -
AO Member
Phil J's Avatar
Join Date: Jul 2007
Posts: 361

Member car:

Fiat Punto Turbo

Re: Hello & Help Please

sounds like MAF fault to me m8...
Phil J is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: Hello & Help Please

Hello and welcome to AO Phil
Status: - Update
Posts: n/a
Re: Hello & Help Please

hiya and welcome to AO...

all the best

Status: Stepgrandfather....
AO Member
alfarich156's Avatar
Join Date: Aug 2006
Location: United Kingdom
County: Nottinghamshire
Posts: 183
Re: Hello & Help Please

Hi and welcome
alfarich156 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

« Sandy | Hello!! »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome