147 Advice - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 16-09-15 Thread Starter
Status: -
Merlan's Avatar
Join Date: Sep 2015
County: -
Posts: 2
147 Advice

Hi Guys

New to the site but Alfa fan for a long time.
I recently bought a 147 T-Spark Selespeed.
I picked it up very cheap but the car has been abused. For now I just want to get it running. We changed the computer box and it starts up and sound good. Its giving Selespeed error. I notice the Pump in the engine bay is out off the car. I am going to fit it back this weekend but I suspect that is damaged and they removed it and parked the cart off. Any idea of price of another part or if somebody can repair it.

Guys I need alot of advice on this car so please share.
Attached Images
File Type: jpg IMG-20150916-WA0006.jpg (145.8 KB, 2 views)
File Type: jpg IMG-20150916-WA0005.jpg (105.1 KB, 1 views)
File Type: jpg IMG-20150916-WA0003.jpg (101.4 KB, 1 views)
File Type: jpg IMG-20150916-WA0002.jpg (111.6 KB, 2 views)
Merlan is offline  
Sponsored Links
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Welcome to AO

Have a look in the relevant 147 tech lounge for advice
BigFoot is offline  
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Welcome To‵⁀) ✫ ✫ ✫.
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛ 。* ♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
SCGT is offline  
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,684
Images: 20
Welcome to AO, hopefully some in the Tech Lounge can help.
David P is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome
Durty dog is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

147 , advice

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome