Bose stereo replacement - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-09-07 Thread Starter
Status: -
Join Date: Sep 2007
Posts: 2

Member car:

156 JTD Lusso

Bose stereo replacement

I'm new to this forum but have owned Alfa's for years,most recently having a spider but having replaced it with 156 JTD Lusso for my newly expanding family. The car is kitted out with the Bose speaker system but previous owner(s) seemed to have removed the original head unit and replaced it with a Sony remote control single CD unit that is no longer operable by the steering wheel controls. Can anyone assist me with what should be there so I can get the Bose system and steering wheel controls up and running properly. Should there also be an amp fitted with this system?
Denners is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Bose stereo replacement

Sorry mate, can't help you but hopefully someone around will.

Welcome onboard
BigFoot is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: Bose stereo replacement

Hi Denners welcome to AO Check out the tech section for your alfa
classicgal93 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

bose , replacement , stereo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome