Hello indeed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 03-09-07 Thread Starter
Status: -
Join Date: Jun 2007
Posts: 2

Member car:

Alfa 147 2l

Hello indeed

Have owned a 5 year old 147, 2l twinspark for 18months now.

On the 3rd gearbox already (luckily the 1st and 2nd boxes were changed under warranty before it ran out).

Hefty garage bills for new cambelt, clutch and tyres too though. All friends are saying "I told you so" shouldn't have bought an Alfa as they're unreliable and "money pits".

Still enjoy driving it though. Not sure we can justify keeping it much longer if it is going to go on costing this much to run... one lives in hope!

A new rattle has started which is already worrying the bank manager.
jmtaylor73 is offline  
Sponsored Links
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Hello indeed

Hello and Welcome !!
nomad is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Hello indeed

Benvenuto a AO
BigFoot is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: Hello indeed

Hi JM, welcome to this great site, check out our tech sections for more help and info
classicgal93 is offline  
Status: diem25.org
Club Member
Membro Premio
Elvis Presley's Avatar
Club Member Number: 59
Join Date: Aug 2006
Location: In a rockin good place
County: Memphis
Posts: 72,966
Images: 5

Member car:

A galleon

Re: Hello indeed

when is it rattling - on startup?
Elvis Presley is offline  
(Post Link) post #6 of 9 Old 04-09-07 Thread Starter
Status: -
Join Date: Jun 2007
Posts: 2

Member car:

Alfa 147 2l

Re: Hello indeed

There's a rattle when accelerating from 1st to 2nd then it goes. I'm wondering if it is the exhaust going.
jmtaylor73 is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: Hello indeed

Welcome to AO

Sorry to hear about all your problems
dpat is offline  
Status: - Update
Posts: n/a
Re: Hello indeed

hiya and welcome to AO...

all the best

Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Hello indeed

Hello and welcome to AO.
rammy is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome