Selespeed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 22-08-07 Thread Starter
Status: -
Join Date: Aug 2007
Posts: 1
Help Selespeed

I am having major problems with my Selespeed gearbox. It won`t let me select gears but once the car cools down it starts working again. The selespeed oil level is fine as I check it daily. New box fitted in Aug 2005. Anybody got any solutions as to the problem. Cheers !
cybernik is offline  
Sponsored Links
Status: Wihout heart we would be mere machines
AO Member
Vas's Avatar
Join Date: Jul 2007
Location: Switzerland
County: Aargau
Posts: 92
Images: 14
Re: Selespeed

Have a look at the discussion thread below. There have been other people with similar problems, which have been proven quite tricky to sort out...
Vas is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: Selespeed

Hi hope you get your alfa problems sorted quickly
classicgal93 is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: Selespeed

Hello and welcome to AO

Hope you get it sorted OK
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Selespeed

Hello and Welcome !!
nomad is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: Selespeed

Welcome to AO
dpat is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Selespeed

Welcome and good luck with the problem
BigFoot is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Selespeed

Hello and welcome to AO.
rammy is offline  
Status: - Update
Posts: n/a
Re: Selespeed

hiya and welcome to AO..

all the best


Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome