frustrated 156 owner - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 17-08-07 Thread Starter
Status: -
Join Date: Aug 2007
Posts: 1

Member car:

156 1.8 t spark

frustrated 156 owner

Hi there ,I'm a proud owner of a 156 1.8 t spark .I'm having bother with it though ,tends to missfire when warmed up .Just replaced the CAT and am about to fit a new set of coils, will this help or could there be something else apart from plugs ?
Tubthumper1 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Re: frustrated 156 owner

Hi Tub welcome to AO check out our tech section for more info
classicgal93 is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: frustrated 156 owner

Hello and welcome to AO
Status: - Update
Posts: n/a
Re: frustrated 156 owner

hiya and welcome to AO

all the best

Status: -
AO Member
Gentari's Avatar
Join Date: Jun 2007
Location: Norfolk
Posts: 938
Images: 33
Re: frustrated 156 owner

Hi and welcome to AO
Gentari is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: frustrated 156 owner

Hello and Welcome !!
nomad is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , frustrated , owner

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome