166 24v won't start - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 10-08-07 Thread Starter
Status: -
AO Member
mcqueenmachine's Avatar
Join Date: Feb 2007
Location: manchester
Posts: 10
166 24v won't start

We seem to have all of the conditions and materials required for internal combustion but it just refuses to start. An AA man came poked about a bit and - I have to say - made a surly and cursory attempt to start it. Flattening the battery in the process. All of the requirements for internal combustion would appear to be present and correct. It coughs if you crank it over - but then shows no further sign of life. Is this, perhaps, an outside temperature sensor that's telling the engine its in the Arctic Circle rather than East Lancashire and dumping loads of fuel in the engine wetting the plugs - platinum tipped, mark you -- and flooding the bores?

I don't know - but I bet a few of you do.

Apologies if there are numerous posts about this already - I'm new.
mcqueenmachine is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: 166 24v won't start

Hi there , welcome if you post in the tech lounge you will get more replies http://www.alfaowner.com/Forum/alfa-164-and-166/ , enjoy the site
classicgal93 is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: 166 24v won't start

Hello and welcome to AO

Hope you get it sorted OK
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: 166 24v won't start

Hello and welcome to AO.
rammy is offline  
Status: Standby.........
AO Platinum Member
mr.orange's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:


Re: 166 24v won't start

Hello and welcome
mr.orange is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: 166 24v won't start

Hello and Welcome !!
nomad is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Re: 166 24v won't start

Hi and welcome to AO!
Enjoy your stay
Al Faromeo is offline  
Status: - Update
Posts: n/a
Re: 166 24v won't start

hiya and welcome to AO

all the best


Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

166 , 24v , start

« Wheels | Hello Post »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome