Hello and help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 11 Old 30-07-07 Thread Starter
Status: -
Join Date: Jun 2007
Posts: 2

Member car:

156 1.8

Thumbs Up Hello and help

Hi everyone. This is my first post so please be gentle. Approx 3 months ago i had a second hand engine fitted in my 1.8 TS and it was running great till a few days ago. For some reason when i start her up it wont go above 3000 rpm then after driving for a few miles it goes back to normal. Tried an ecu and throttle reset but no different. Any help would be really appreciated.
twiggy3568 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Hello and help

hiya and welcome to AO..

could be MAF or Lambda sensor

all the best

Mark Alfa
Status: - Update
Posts: n/a
Re: Hello and help

Hello and welcome to AO

Hope you get your problem solved!
Status: -
AO Member
gray69's Avatar
Join Date: Mar 2007
Location: stockton on tees
Posts: 330
Images: 2

Member car:

156 veloce

Re: Hello and help

Hi and welcome to AO Twiggy,could try the 156 tech forum
gray69 is offline  
Status: Standby.........
AO Platinum Member
mr.orange's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:


Re: Hello and help

Hello and welcome
mr.orange is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Hello and help

Hello and welcome to AO.
rammy is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Hello and help

Hello and Welcome !!
nomad is offline  
Status: dossing
AO Silver Member
alfaspence's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Suffolk
Posts: 2,749
Re: Hello and help

welcome, and good luck
alfaspence is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: Hello and help

Welcome to AO
dpat is offline  
Status: Je suis l'dauphin d'la place Dauphine
AO Platinum Member
Al Faromeo's Avatar
Join Date: Apr 2005
Location: Netherlands
County: Limburg
Posts: 25,338
Images: 8
Re: Hello and help

Hi there & welcome to AO
Hope you find what you're looking for!
Al Faromeo is online now  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: Hello and help

Hi Twiggy, hope you stick around and enjoy the site
classicgal93 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome