2001 Alfa 147 2.0 TS - My First Alfa! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 14-05-15 Thread Starter
Status: -
AO Member
JoeH147's Avatar
Join Date: Apr 2015
Location: Lancashire
County: UK
Posts: 57

Member car:

2005 GT JTS 2.0l

2001 Alfa 147 2.0 TS - My First Alfa!

Hello from Lancashire,

Been lurking on here gathering up all the useful advice, this forum is an absolute goldmine. I thought I better introduce myself, I'll be needing help soon, I can feel it...

I've grown up with Alfas, since I can remember, my dad had a few 33s, a 75, a 146 and a 147. He now has a GTV and is on his second Giulietta, so I could say its in my blood. I had the Tarquini 155 posters on my bedroom wall, the Tamiya models. For some reason I never took the plunge to get one myself until recently, I think I wanted to wait until I could do them justice and get something really perfect. I've tinkered with various shabby MGBs, Minis, a Volvo Amazon, 2CVs and perfunctory moderns, but I always promised myself I'd become an Alfa owner one day. My dream car is a GT Junior, but thats going to take a lot of penny saving...

I gave in to the urge though and decided not to wait for the "one" and just get something to play with. I had a budget of 2000, and picked up this 72,000 mile 2 litre TS Lusso (the leather seats are incredible) for 750, and spent 800 immediately getting a full service, a cam belt change and some new wishbones. I caught it just in time, the alternator belt was about to shred itself and tear through the belt.

I'm amazed how revvy they are, they thrive in 3rd, just riding the torque, and the noise is superb. I tried a few 147s before I got this, mostly from dealers that wanted 2000 for cars without MOTs and flat batteries, so I was really chuffed to find this one for a low price in good condition, it felt right, I took a gamble but I'm hoping its going to pay off. Its a little shabby but I'm slowing improving it, I've fixed the heated seats, got a new glovebox to replace the broken catch, cleaned all the furriness off various connections, and fingers crossed, its running great. Just need to sort out a few creaks and rattles from underneath and its going to get better and better. It had been stood a long time, and I can feel it slowly coming back to life, they need to be used.

I'm taking the long way to work now, I get Alfas even more now I'm driving one, and I can safely say I'm hooked.

I'm going to need some diagnostic advice, but I'll post that in the right section. My bluetooth ELM237 seems to work, but its registering no fault codes at all, yet I've already had the dreaded Motor Control System Failure, so unsure whether this device can access the engine ECU. However, after some long "Italian Tune Ups" I've not had that for a while, so it could be battery related due to its inactivity, I just don't know. I've got some curious temperature gauge/sender or fan issues too, just got the high speed fan kicking in currently, but doing the fan test with the ignition on MAR and the temp sender disconnected gives me both speeds, very odd...

Anyway, here's a shot of it looking all moody near a lake in Calderdale. Just need to track down some 17" Sport wheels now!

What a great forum this is, looking forward to contributing, cheers, Joe
Attached Images
File Type: jpg 147_2.0_TS.jpg (177.6 KB, 2 views)
JoeH147 is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Hi Joe waving nice intro, glad you found us!
classicgal93 is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,647
Images: 20
Welcome to AO Joe & congrats on your 147
David P is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Welcome to AO Joe
BigFoot is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome :wave:
Durty dog is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

147 , 2001 , alfa

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome