Hello and Help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 19-07-07 Thread Starter
Status: -
Join Date: Jul 2007
Posts: 1

Member car:

166 3.0 Auto

Hello and Help

Hello to all the members.

I have owned a 166 3.0 Auto now for four years and have had my share of trouble.

Just 20 miles after I purchased the car the cam belt broke and bent 20 of the valves. Unfortunately it was a private sale so I had no comeback there. Up to this point the car had a full service history and the belt was changed at 72000, it broke at 100000. It appears that it had not been tensioned correctly by the Alfa dealer. So to all that have had a belt fitted be careful as I have heard of at least four other similar cases.

Recently I have had an other problem. This time the auto gearbox went in to the emergency mode, which only gives you two gears (reverse and third). What ever caused the ECU to revert to emergency cured itself 20 minutes later.

This then leads to the question for people out there. Does anyone know of a reasonably cheap scan tool that can talk to all the systems in the 166, not just the engine?


Donald Campbell is offline  
Sponsored Links
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Hello and Help

Hello and welcome to AO.
rammy is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: Hello and Help

welcome to AO Donald, try posting your query in the technical model forum for the 166
dpat is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Hello and Help

Hello and Welcome !!

Sorry to hear of your problems dude, hope you get them sorted soon !!
nomad is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: Hello and Help

Hi Donald, welcome, sorry to hear of your problems, try the tech lounge like Dpat said http://www.alfaowner.com/Forum/alfa-164-and-166/ , good luck and enjoy the site
classicgal93 is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: Hello and Help

Hello and welcome to AO Donald
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Hello and Help

Hi Donald, welcome to AO
BigFoot is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome