Please help me - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 28-06-07 Thread Starter
Status: -
Join Date: Jun 2007
Posts: 1
Please help me

I have a 1969 Alfa Romeo Berlina with a bit of a clutch problem. My mechanical linkage to the hydraulics is coming apart. The shaft directly under the drivers seat has broken off at the end and I am having a terrible time locating something that will fit or fix the issue. Can anyone help me??????? I would love comments on past expierence as this is my first romeo and I enjoy it and don't want to have to scrap it.
lostcoz is offline  
Sponsored Links
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: Please help me

Hi Lostcoz, welcome to AO, we have a classics tech lounge where you will get more help Keep the faith, she'll be worth it Enjoy the site
classicgal93 is offline  
Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Please help me

Hello and welcome to AO.
rammy is offline  
Mark Alfa
Status: - Update
Posts: n/a
Re: Please help me

Hello and welcome to AO
Status: - Update
Posts: n/a
Re: Please help me

hiya and welcome to AO

all the best

Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Please help me

Hello and Welcome !
nomad is offline  
Status: Being of sound body
AO Platinum Member
73GTVJim's Avatar
Join Date: Mar 2006
Location: United Kingdom
County: Greater Manchester
Posts: 23,159
Images: 32
Re: Please help me


I have no experience of the problem but it could be the spring which you can buy from Classicalfa or EB Spares. If not, give them a bell and they may have the part.
73GTVJim is offline  
Status: -
AO Member
Alex_Alfa33's Avatar
Join Date: Apr 2007
Location: United Kingdom
County: Essex
Posts: 959
Re: Please help me

Hello n welcome to AO! Hope you enjoy
Alex_Alfa33 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome