Me and my Alfa - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 11 Old 23-06-07 Thread Starter
Status: -
Join Date: Jun 2007
Location: Baden CH
Posts: 1

Member car:


Me and my Alfa

Hi All,

I joined here because my headlights did not adjust to the leveling control on the dash. They were in the lowest position making my evening drives a "special" experience.

After seeing that many people had a problem with but nobody had a solution I feared that it would be a trip to the dealer for me.

But first, I thought I better try and find something myself.
First I opened the fuse box under the steering weel and checked all fuses. All was OK as expected.
Then off to the lights and try to adjust manually by turning the adjuster screw. Fortunately, nothing was locked because the lights moved up and down.

So, totally dissapointed I slammed down the fuse cover and was ready to go to the dealer.

I got disturbed in my swearing when I heared a buzzing sound. Going to the front of the car, I saw that the lights were moving up!

So to all of you that have lighting problems, slam it smack it swear at it but first and foremost, take some totally useless action and unscrew the fuse cover and slam it shut hard!

It just may help you.

Good luck to all,

jjdeboer is offline  
Sponsored Links
Mark Alfa
Status: - Update
Posts: n/a
Re: Me and my Alfa

Hello and welcome to AO John
Status: It's the silly season
AO Gold Member
Dirk's Avatar
Join Date: Apr 2007
Location: Plett
County: South Africa
Posts: 9,803
Images: 10

Member car:

V6 Sportswagon

Re: Me and my Alfa

Hi John,
sorry to hear about your problems, hope that got it sorted and it is fixed now.
Welcome to AO

Dirk is offline  
Status: -
AO Member
Alex_Alfa33's Avatar
Join Date: Apr 2007
Location: United Kingdom
County: Essex
Posts: 959
Re: Me and my Alfa

Hello n welcome to AO! hope you enjoy
Alex_Alfa33 is offline  
Status: Standby.........
AO Platinum Member's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:


Re: Me and my Alfa

Hello and welcome is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Me and my Alfa

Welcome onboard John
BigFoot is offline  
Status: - Update
Posts: n/a
Re: Me and my Alfa

hiya and welcome to AO...

all the best

Status: -
AO Gold Member
rammy's Avatar
Join Date: Feb 2007
Location: burton on trent
Posts: 7,719
Re: Me and my Alfa

Helo and welcome to AO.
rammy is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Me and my Alfa

Hello and Welcome !!
nomad is offline  
Status: I got cakes..FISHCAKES!
AO Silver Member
Voo's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: Oxfordshire
Posts: 1,915
Images: 7

Member car:


Re: Me and my Alfa


I am slightly concerned about your technical advice as I heard no mention of a hammer being used at all
Voo is offline  
Status: Still Happily Married..........
AO Platinum Member
dpat's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Cheshire
Posts: 32,403
Images: 20
Re: Me and my Alfa

welcome to AO
dpat is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome