the italian bug!!!!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 10-12-14 Thread Starter
Status: -
AO Member
Join Date: Dec 2014
Location: uk
County: -swindon, england
Posts: 18
Well Happy the italian bug!!!!!!

Hi there,
New to the Alfaowners!!! although I have had three Alfa's a 3.2 V6 GT, a 1.9 Mjet Jtd GT and now a poorly 159 sportwagon.
I am a classic car fanatic and have about 14 cars but trying to reduce down to a sensible number!!! well under 10
shawnhindon156 is offline  
Sponsored Links
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,648
Images: 20
Welcome to AO, hope you get your 159 sorted soon
David P is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,052
Images: 2
Big parking lot ? well done welcome to AO waving
classicgal93 is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Welcome to AO
BigFoot is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome :wave:
Durty dog is offline  
(Post Link) post #6 of 9 Old 12-12-14 Thread Starter
Status: -
AO Member
Join Date: Dec 2014
Location: uk
County: -swindon, england
Posts: 18
Thanks guys!!!
I had a big problem with jagggs!! but now I've seen the light!! Italian all the way!! but the 156 SW is proving to be a challenge!!! I rebuilt the engine on my Alfa GT JTD but an alternator on the 156 is causing massive headaches!! argghhh
shawnhindon156 is offline  
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Welcome To‵⁀) ✫ ✫ ✫.
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛ 。* ♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
SCGT is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  
(Post Link) post #9 of 9 Old 17-12-14 Thread Starter
Status: -
AO Member
Join Date: Dec 2014
Location: uk
County: -swindon, england
Posts: 18
I also own a Maserati 4200 GT so my Italian bug is really taking control!!!
shawnhindon156 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

bug , italian

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome