Yet another new member! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 20-10-14 Thread Starter
Status: -
AO Member
alfadodge's Avatar
Join Date: Oct 2014
Location: United Kingdom
County: Hertfordshire
Posts: 182
Images: 12
Yet another new member!

Hi all, another newbie just joined!

Been lurking around for a while, usually when I have a problem with my 156 and want to see what others do in the same situation!

Decided to take the plunge after my last episode, just over a week ago, when my key fob wouldn't turn the alarm off, but I'll get into that elsewhere on the forum.

I say I've been lurking for a while but I actually bought the car from Veloces in Barnet, north London about 10 years ago, when it was just 2 and a bit years old. It's a 2002 156 SW 2.0 JTS Veloce in red.
I chose it cos I needed an estate and I thought it was the best looking estate around
Sure, it's had its fair share of problems over the years, most of which will be well known to other Alfa owners but the longer I keep it, the longer I want to continue keeping it! Especially when I read that some say the 159 isn't as nice to drive. But that's something I need to investigate, as that was going to be my natural progression!

Not very good, or recent pics, but you get the idea....

I was trying to choose a username that included part of my name and part of the cars model name but there appears to be loads of Roberts that own 156 / SW / Veloce, so I went with something else!

The 'dodge' in my user name is cos of my other car interest. My brother & I have a 1963 Dodge Polara 500 which we got in 2004 and a 1969 Plymouth Sport Satellite, which we bought as 23 year olds in 1985! There, that's given my age away!

I'll post a couple of pics of them if anyone's interested another time.

Anyhoo, that'll do for now.


alfadodge is offline  
Sponsored Links
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,627
Images: 20
Welcome to AO Rob, hope you get the key fob & alarm issue sorted
David P is offline  
(Post Link) post #3 of 7 Old 20-10-14 Thread Starter
Status: -
AO Member
alfadodge's Avatar
Join Date: Oct 2014
Location: United Kingdom
County: Hertfordshire
Posts: 182
Images: 12
Thanks David - hopefully zaksystems chris will be fixing one of my fobs over the next few days, then we'll see how the alarm is after that!
alfadodge is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Welcome To‵⁀) ✫ ✫ ✫.
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛ 。* ♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
SCGT is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome :wave:
Durty dog is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Welcome to AO Rob
BigFoot is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome