Hello - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 11 Old 26-03-07 Thread Starter
Status: -
Join Date: Sep 2006
Posts: 3
Moaning Hello

Hi, I have just got round to introducing myself; I bought my Alfa 147 2.0 TS last August (03 plate), and am currently having a nightmare. I recently got it serviced and timing belt replaced, but on Saturday whilst driving down the motorway, there was a bang, rattle and white smoke poured out the exhaust. The Engine light lit up and everything died. Now my Alfa garage is telling me I need a new engine as there is so much damage!!!!

I'm hoping my warranty will cover this!!!

FlyingDodo is offline  
Sponsored Links
Mark Alfa
Status: - Update
Posts: n/a
Re: Hello

Hello and welcome to AO
Status: - Update
Posts: n/a
Re: Hello

welcome to AO dude...

really bad luck..hope your warranty covers it

Status: Standby.........
AO Platinum Member
mr.orange's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:


Re: Hello

Hello and welcome
mr.orange is offline  
Status: Sold the 147
AO Member
Warsash 147's Avatar
Join Date: Mar 2007
Location: Southampton
Posts: 443
Images: 1
Re: Hello

I got an 02 147 TS. My cambelt slipped at 59K & warranty company coughed up for repairs (£1400) as handbook said to change it at 72K. Ironically it was booked in for a changed the following week. Would never let a belt go more than 50K now. But I still love my Alfa
Warsash 147 is offline  
Status: -
AO Member
wirefree's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Greater London
Posts: 35
Images: 17
Re: Hello

Hello all.

I've just "upgraded" my 156 JTS Lusso to a 159 3.2 Q4. What a car!!!

The 159 is obviously a replacement for the 156, but really driving the 2 of them you wouldn't know it. The 159 is so much better in every respect.

One thing that's ****ing me off and I haven't got a solution yet is how to get my DAB radio installed and working with the steering wheel buttons on the 159. Also wondering how best to add Bluetooth to this setup. Really wanted Blue&Me but since I bought a new one "off the shelf" rather than ordering it via the dealer I had to take the car that was available rather than the exact car I wanted.
wirefree is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: Hello

Hi and welcome to this great site, enjoy
sorry to hear of your engine problems, hope it's covered.
classicgal93 is offline  
Status: diem25.org
Club Member
Membro Premio
Elvis Presley's Avatar
Club Member Number: 59
Join Date: Aug 2006
Location: In a rockin good place
County: Memphis
Posts: 72,948
Images: 5

Member car:

A galleon

Re: Hello

hi dodo, fingers crossed for you
Elvis Presley is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Hello

Hi there, welcome to AO

Wish you the best with your problem.
BigFoot is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Hello

Hello and Welcome !!

Hope you get your problems sorted soon..... and under warranty of course !!
nomad is offline  
Status: happier today
AO Silver Member
merlin's Avatar
Join Date: Jun 2006
Location: Kent
Posts: 2,437
Well Happy Re: Hello

Welcome to AO Dodo, wern't you in Primeval the other week
merlin is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome