Hello Everyone - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 26-02-07 Thread Starter
Status: -
Gadgetrob's Avatar
Join Date: Feb 2007
Location: Wellingborough & Corsham
Posts: 4

Member car:

166 3.0 V6 Lusso

Well Happy Hello Everyone

Hi Everyone,

I have just got a 166 V6 with Xenon lights and they seem to be set too low - can adjust the driver's side but the passenger side doesn't adjust as far.

Both motors in correctly (thanks for the other tips everyone).

Any ideas?



Hi Everyone,

Found the problem - well 2 of them actually:

1. The spring retaining clip in the N/S light had been bent (presumably by some ham-fisted person who changed the sidelight). As a result, the bulb wasn't being held securely and properly - it was actually pointing to the left, hence the weird beam pattern and the low level. Took bulb out (carefully) and bent the retaining clip back into shape. Job sorted!

2. Self-levelling link rods had broken at the 'ball-joint' - get wet, rust and seize up. New rods purchased (approx. £13.00 each) and fitted.

Now the lights work, self-level and produce better then expected illumination, given other comments on brightness etc.

Thanks everyone for the info in the other posts - very helpful.


Last edited by Gadgetrob; 09-05-07 at 23:13. Reason: Update
Gadgetrob is offline  
Sponsored Links
Mark Alfa
Status: - Update
Posts: n/a
Re: Hello Everyone

Welcome to AO
Status: -
AO Platinum Member
Roswell's Avatar
Join Date: Mar 2004
Location: United Kingdom
County: Durham
Posts: 33,630
Images: 15
Re: Hello Everyone

Hi Gadgetrob, welcome to AO.
Roswell is offline  
Status: Standby.........
AO Platinum Member
mr.orange's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:


Re: Hello Everyone

Hello and welcome
mr.orange is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Hello Everyone

HI there, welcome to AO
BigFoot is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Re: Hello Everyone

Hi and welcome, congrats on the 166 purchase hope you enjoy the site
classicgal93 is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Hello Everyone

Hello and Welcome !!
nomad is offline  
Status: I'm back
AO Silver Member
Gramat's Avatar
Join Date: Sep 2006
Location: Macedonia
Posts: 1,422
Images: 46
Re: Hello Everyone

Welcome to AO
Gramat is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome