Hello.... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 12 Old 25-02-07 Thread Starter
Status: -
AO Member
Join Date: Feb 2007
Posts: 11

Member car:

146ti 2.0L 16v


Hello guys.. just introducing myself, I have just bought a 146 ti 2 litre for a measly 2000, with 80k on the clock, with nice cream leather all round and dark blue metallic paintwork....the car is great fun to drive and reasonably pokey aswell so, I am happy with my purchase so far..

No expert with cars but have always loved the Alfa's so decided to give them a go despite people warning against them because of reliability, build quality blah blah...

Would like to know if anyone can give me any advice on any obvious 146ti faults or glitches that I should watch out for, although mechanically the cars runs near perfect at the moment.

Only fault I have is that the heater/fans do not work on settings 1,2, and 3, but kick in on setting 4 and then the heater motor makes a loud "I'm going to blow up" noise, although it works fine.

Thanks in a dvance for any help, I will repost in the correct forum with any questions!

Biddle is offline  
Sponsored Links
Mark Alfa
Status: - Update
Posts: n/a
Re: Hello....

Welcome to AO Bid You've come to the right place for info
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Re: Hello....

Hi Bid, welcome to this great site, hope you enjoy looking around and posting, Cheers
classicgal93 is offline  
Status: 3.2 Busso powered
AO Gold Member
AlfaMartini's Avatar
Join Date: Sep 2005
Location: Abu Dhabi
Posts: 7,669
Re: Hello....

Hi Bid, And welcome to AO

Check out this lounge for 146 tech' advice...

AlfaMartini is offline  
Status: I'm back
AO Silver Member
Gramat's Avatar
Join Date: Sep 2006
Location: Macedonia
Posts: 1,422
Images: 46
Re: Hello....

Welcome to AO
Gramat is offline  
Status: Relaxed
AO Platinum Member
GJ's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Herefordshire
Posts: 17,658
Images: 13

Member car:

Spider S4

Re: Hello....

Welcome to AO
GJ is offline  
Status: -
AO Platinum Member
nomad's Avatar
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:


Re: Hello....

Hello and Welcome !!
nomad is offline  
Status: -
AO Platinum Member
Roswell's Avatar
Join Date: Mar 2004
Location: United Kingdom
County: Durham
Posts: 33,630
Images: 15
Re: Hello....

Welcome to AO.
Roswell is offline  
Status: - Update
Posts: n/a
Re: Hello....

welcome to AO dude....

all the best
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: Hello....

Hi Bid, welcome to AO
BigFoot is offline  
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: Hello....

Full blower power, but makes a racket! Could be dry, worn, blower armature bearings. Maybe the 147 chaps can tell you how to get at it. Bit of lubrication might sort it. Not sure whether it's a radial or axial fan, this could be clobbering the heater casing if the bearings are badly worn. zf
zulu ferret is offline  
Status: Standby.........
AO Platinum Member
mr.orange's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:


Re: Hello....

Hello and welcome
mr.orange is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome