My First Alfa - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 25-07-14 Thread Starter
Status: -
AO Member
Join Date: Jul 2014
County: -
Posts: 19

Member car:

156 1.6TS 2001

Help My First Alfa


Last week I took the plunge a purchased my first Alfa. A 156 1.6TS 2001 95000 Miles for the princely sum of 500
It has the odd cosmetic blemish here and there, but in the past week Ive fallen in love with it.
However I have a small problem with the fact that the brakes keep sticking on. There is plenty of wear in the pads and discs but after driving 9-10 miles the brakes start to squeal, I rinsed the brakes and was greeted with a big cloud of steam from 3 of the 4 wheels. All fluids are at the correct level.
I spoke to the previous owner who said it had been kept under a car cover for 11 months without moving.
Can the callipers have got stiff and be unable to retract properly.
Have you any suggestions on how to proceed, is it just a case of getting the brakes dismantled, cleaned and lubricated or could this be more serious.
For a strip down, clean and lubricate, what could the cost be?
MKEDGE is offline  
Sponsored Links
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,687
Images: 20
Welcome to AO & to Alfa ownership, congrats on your 156

Check out the Tech Lounge Alfa 147, 156 & GT - Alfa Romeo Forum for advice, info & help.
David P is offline  
(Post Link) post #3 of 7 Old 25-07-14 Thread Starter
Status: -
AO Member
Join Date: Jul 2014
County: -
Posts: 19

Member car:

156 1.6TS 2001

Thanks David P for the welcome, i'm a bit suprised nobody has offered any insight to my dilemma. I'm booked in for a "free" brake check at my local Kwik Fit, they are by law obliged to tell me of any work that may need done, my choice if they do it or I use local cheaper labour but I'll possibly use OEM parts. But if nothing needs replaced they have to return my car in full working order. I have nothing to loose at the moment. If not OEM parts, who is a good substitute?
MKEDGE is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Hi and welcome to AO waving . The members are very helpful on AO but they help people in the tech sections This is the welcoming section.
classicgal93 is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome :wave:
Durty dog is offline  
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Welcome To‵⁀) ✫ ✫ ✫.
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛ 。* ♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
SCGT is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome