St - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 12 Old 06-01-07 Thread Starter
Status: -
Newbie
 
Join Date: Jan 2007
Posts: 1

Member car:

Alfa 147

St

Hi there,
I'm ST. I have an '02 147 TS Lusso with about 64000miles on the clock.
Driving yesterday and the 'low battery charge' warning flashed up and my power steering went.
any suggestions gratefully recieved
Cheers
stmarkwell is offline  
Sponsored Links
Advertisement
 
Status: I'm back
AO Silver Member
 
Gramat's Avatar
 
Join Date: Sep 2006
Location: Macedonia
Posts: 1,422
Images: 46
Re: St

Welcome to AO
Gramat is offline  
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: St

Hi mate, welcome to AO

Why not try searching on the forum to see if someone's come across the problem before? If not, do post it also in the 147 lounge and fellow drivers should be able to help.

Cheers
BigFoot is offline  
Status: making daily raids across the border
AO Gold Member
 
alfaholic's Avatar
 
Join Date: Aug 2001
Location: United Kingdom
County: Surrey
Posts: 6,451

Member car:

6C 2500

Re: St

Welcome to AO
alfaholic is offline  
Status: -
AO Platinum Member
 
Gary Slegg's Avatar
 
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Re: St

Hi, welcome to AO
Gary Slegg is offline  
Mark Alfa
Status: - Update
Guest
 
Posts: n/a
Re: St

Welcome to AO ST
 
Status: -
AO Silver Member
 
glenda's Avatar
 
Join Date: Jul 2005
Location: Co.Tyrone, N Ireland
Posts: 1,624
Images: 6

Member car:

145 1.8 T-Spark

Re: St

Hi ST welcome along.

Sorry to hear you are having problems with your car, but for what its worth you've come to the right place for technical know-how
glenda is offline  
Status: Spider's ready to go!
Global Mod Team
 
classicgal93's Avatar
 
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,013
Images: 2
Garage
Re: St

Hi ST, glad you joined up, hope you get your problem sorted quickly. Enjoy this great site and all it has to offer. Cheers
classicgal93 is offline  
Status: -
AO Member
 
Gary Gumball's Avatar
 
Join Date: Oct 2006
Location: Newbury, West Berks
Posts: 785
Images: 8

Member car:

TVR Chimaera 400

Re: St

Welcome aboard.
Gary Gumball is offline  
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: St

welcome to AO ST....


all the best



 
Status: -
AO Silver Member
 
Trailbraker's Avatar
 
Join Date: Mar 2005
Location: Ireland
County: -
Posts: 5,179

Member car:

156 GTA

Re: St

My not very mechanically minded guess is possibly a problem with your alternator belt which drives the power steering pump?

Cheers,
TB
Trailbraker is offline  
Status: -
AO Platinum Member
 
nomad's Avatar
 
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:

RRS TDV8 HSE

Re: St

Hello and Welcome !!
nomad is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome