woza1969 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 11 Old 15-12-06 Thread Starter
Status: -
Newbie
 
Join Date: Dec 2006
Posts: 3
woza1969

Hi out there,
I've had a GTV Twin spark for 5 years been fine apart from the normal stuff and a good runner! Until latlely, it now just wont idel, It's like there is no choke on. Hold down the accelorator at 2ooo revs and it's fine. Take off the gas and it dies.

Any ideas out there.

Cheers,
1st time.
woza1969 is offline  
Sponsored Links
Advertisement
 
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: woza1969

Hi mate, welcome to the AO family
BigFoot is offline  
(Post Link) post #3 of 11 Old 15-12-06 Thread Starter
Status: -
Newbie
 
Join Date: Dec 2006
Posts: 3
Re: woza1969

Cheers, seems like there are more people out there with a common headache.

hope this is'nt terminal.
woza1969 is offline  
Status: Sleeping veloce but NOT DEAD!
Unregistered
 
johnboy's Avatar
 
Join Date: May 2006
Location: margate kent uk
Posts: 1,767
Images: 9
Re: woza1969

Hi
im new to this site as well,just did an intro, i would think its your air flow meter

regards john
johnboy is offline  
(Post Link) post #5 of 11 Old 15-12-06 Thread Starter
Status: -
Newbie
 
Join Date: Dec 2006
Posts: 3
Re: woza1969

Thanks for that,im off to the garage now for a quick rip off.

Will post an out come.
woza1969 is offline  
Status: Sleeping veloce but NOT DEAD!
Unregistered
 
johnboy's Avatar
 
Join Date: May 2006
Location: margate kent uk
Posts: 1,767
Images: 9
Re: woza1969

hope it is that,
got those joys to come when i get my gtv on the road

john
johnboy is offline  
Status: making daily raids across the border
AO Gold Member
 
alfaholic's Avatar
 
Join Date: Aug 2001
Location: United Kingdom
County: Surrey
Posts: 6,451

Member car:

6C 2500

Re: woza1969

Welcome, hope you get it sorted
alfaholic is offline  
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: woza1969

welcome to AO dude...



 
Status: Spider's ready to go!
Global Mod Team
 
classicgal93's Avatar
 
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,021
Images: 2
Garage
Re: woza1969

Hi Woza and welcome to this great site, enjoy looking around. Cheers
classicgal93 is offline  
Status: -
AO Platinum Member
 
nomad's Avatar
 
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:

RRS TDV8 HSE

Re: woza1969

Hello and Welcome !!
nomad is offline  
Status: I'm back
AO Silver Member
 
Gramat's Avatar
 
Join Date: Sep 2006
Location: Macedonia
Posts: 1,422
Images: 46
Re: woza1969

Welcome to AO
Gramat is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
woza1969

« hello | Hi! »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome