new alfa owner - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 01-12-06 Thread Starter
Status: -
AO Member
 
madson's Avatar
 
Join Date: Dec 2006
Location: Dublin
Posts: 120

Member car:

147 1.6tspark

Cry Like A Baby new alfa owner

hey, i got my 1st alfa a few weeks ago.... a red 2001 147 1.6ts and i love it even if it has already cost a fortune to fix different things to it.

Within 3 weeks i've had to replace the spark plugs, timing belt and pulley, tensioners, variator, put 2 litres of oil into it, replace 5 different bulbs and replace the wiper blades. I probably could of got away without getting all this done but i did for piece of mind and i really want to look after this car as it really is beautiful.

Dispite getting all the above done i still have issues with the car...... the reverse light doesn't work anymore, it blows the fuse whenever i put it into reverse... i've pulled the light apart, had the switch on the gear box checked, checked the wiring at the fuse box but all good My mechanic reckons its a wire getting caught somewhere. Any suggestions??? My boot light doesn't work either but i don't think the two are linked.
My rear windscreen washer only gives out a small stream of water but i think the line may be clogged somewhere. Again any suggestions on how to fix this??
Also when at high speed(motorway speed 80-120km per hour) and at 2000 to 4000 revs the engine makes strange noises but i'll be getting this checked out by a speciallist in the coming weeks but again any suggestions before i give it to a mechanic are welcome.

it may seem like i have bought a bad car with a few problems but most of these have only come on since i took ownership and i don't care cause i know i can get them fixed and then i'll have a fantastic car.

thanks
madson is offline  
Sponsored Links
Advertisement
 
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: new alfa owner

Hi madson, welcome to the AO family

And thank you for sharing your positive attitude to Alfa ownership with all the AOers!
BigFoot is offline  
Status: -
AO Member
 
sparkoniocv's Avatar
 
Join Date: Nov 2006
Posts: 524
Re: new alfa owner

Welcome aboard madson.
Anyone help madson with his probs.
sparkoniocv is offline  
Status: -
AO Member
 
sparkoniocv's Avatar
 
Join Date: Nov 2006
Posts: 524
Re: new alfa owner

Hey bigfoot you really in tokyo! whats the weather like the other side.
sparkoniocv is offline  
Status: I'm back
AO Silver Member
 
Gramat's Avatar
 
Join Date: Sep 2006
Location: Macedonia
Posts: 1,422
Images: 46
Re: new alfa owner

Welcome to AO
Gramat is offline  
Status: making daily raids across the border
AO Gold Member
 
alfaholic's Avatar
 
Join Date: Aug 2001
Location: United Kingdom
County: Surrey
Posts: 6,451

Member car:

6C 2500

Re: new alfa owner

Hello and welcome
alfaholic is offline  
GJ
Status: Relaxed
AO Platinum Member
 
GJ's Avatar
 
Join Date: Sep 2004
Location: United Kingdom
County: Herefordshire
Posts: 17,658
Images: 13

Member car:

Spider S4

Re: new alfa owner

Welcome to AO

Post your queries in the 147/156 lounge and you'll be inundated
GJ is offline  
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: new alfa owner

welcome to AO dude...


 
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
alfa , owner

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome