Hi i am new to this site and need a little help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 12 Old 16-03-14 Thread Starter
Status: Running sweet
AO Member
Chop78's Avatar
Join Date: Mar 2014
Location: United Kingdom
County: Lincolnshire
Posts: 33

Member car:

166 2.0 ts

Hi i am new to this site and need a little help

Hi i am Chris from N.E Lincolnshire i am new to this site but have read a lot of posts on here regarding my new 166.
I have gone and got myself a black 2004 53 plate 166 2.0 ts for peanuts really, with only 71k on the clock.
This is my second alfa and i have come across a problem i have never had before,
After sorting a few other little problems out i now have this starting today, I pulled up in my drive after going for a 14 mile run, everything was spot on except the engine temp a little low and went to turn off the ignition and get out and noticed the ignition still on, i sat back in the car and the engine was still running too, I still had my key in my hand and i could rev the engine, Radio was still playing away and all the ignition warning lights were on.
If anyone has any ideas what may be up with her please can you let me know as i want to get her sorted out.
I have an idea of may be ignition relay or ignition barrel ? but i am unfamiliar with the fues and relay lay out on this car.

any thoughts welcome

166 2004 2.0 twin spark

Last edited by Chop78; 16-03-14 at 18:26.
Chop78 is offline  
Sponsored Links
Status: 17 inch teledials :)
AO Silver Member
Join Date: Jul 2013
Location: Ireland
County: Kildare
Posts: 1,247
Images: 4

Member car:

916 gtv 2.0

Hi and welcome...No experience of this on either my 156 or gtv (if you find out whats causing it, let me know so I can do it to my friends one and freak him out)

You're best bet would be to post in the 166 forum as someone there may have came across it
Alfa 164 & 166 - Alfa Romeo Forum
Scortho is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,055
Images: 2
Welcome to AO waving I hope you get your ignition sorted.
classicgal93 is offline  
(Post Link) post #4 of 12 Old 16-03-14 Thread Starter
Status: Running sweet
AO Member
Chop78's Avatar
Join Date: Mar 2014
Location: United Kingdom
County: Lincolnshire
Posts: 33

Member car:

166 2.0 ts

Thank you i will post it in that group now
Chop78 is offline  
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,668
Images: 20
Welcome to AO, hope you find some help in the Tech Lounge
David P is offline  
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome :wave:
Durty dog is offline  
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,083
Images: 22
Hi, a warm welcome from the Lincs Mob !!!

We are quite an active little group here so it would be very nice to see you in the Lincs Lounge and at some of our Meets soon. Lots of these coming up, some great ones coming up over the next few Months.

I have yet to finalize our April Meet, it will probably be an Evening Pub Meet around the middle of the Month, keep an eye on the Lincs Lounge for the announcement.

Our “ regular “ Meets are usually ( but not always ) on a Thursday evening and are scattered around the County and these are interspersed with our “ special “ Meets throughout Spring, Summer and Autumn. In the Winter we usually have a few Breakfast and afternoon Meets to keep us going. We always have a lot of Events during the year, some of them are just Beer and Chat type things but a lot of very special ones too, we don’t get bored here in the Flatlands. Keep an eye on the Lincs Lounge for full details.

You might want to add your details on to the “ Names, Locations and Cars “ Thread too, I generally don’t do this unless people “ask “ in there, don’t wish to give away any secrets !


Follow the Links to see what is going on and join in, I can pretty much say that you won't regret it. Apart from myself everyone else in the Lincs Section are very nice people.........

From the Lincs Lounge also follow Links and see what we have been up to in the past, some cracking Meets and some great pictures.


http://www.alfaowner.com/Forum/linco...es-thread.html (Links To Meetings Pictures Thread.)

Don't forget to look at the " Stickies " right on top of the Lincs Lounge page.



Have you seen the Lincolnshire Lounge ? Don't stay off the radar, come on in and have a look !

Next Event - TBA

Look Here ! -TBA

email: nige005@alfaowner.co.uk

Old radar men never die - their echoes just fade away in accordance with the inverse fourth power law.
Nige005 is online now  
Status: R.I.P Paula :(
AO Rosso Alfa Member
Shant Ole's Avatar
Join Date: Dec 2009
Location: Cyprus
County: Larnaca
Posts: 57,686
Hello and welcome to AO
Shant Ole is offline  
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Welcome To‵⁀) ✫ ✫ ✫.
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛ 。* ♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
SCGT is offline  
(Post Link) post #10 of 12 Old 18-03-14 Thread Starter
Status: Running sweet
AO Member
Chop78's Avatar
Join Date: Mar 2014
Location: United Kingdom
County: Lincolnshire
Posts: 33

Member car:

166 2.0 ts

Thank you all for the warm welcome everyone, i have been all over my car and i found a melted fuse in the bulk head row it's a 30amp nearest to the passenger side of the row, can anyone tell me what this is for please ?? i think i have a short some were for this to melt. The funny thing is it never blew the fuse just melted it so i was wondering if it should be a 30 or smaller and it is hiding another problem, i will be tracing it back today ( if i can see were it goes to ) and looking behind the glove box for more relays and fuses as i striped all the other fuses and relays out yesterday as well as the blue and green box from drivers side under steering wheel all cleaned and put back.
Another question behind the battery on my 166 there is a fuse and 2 spaces for relays but only one relay is there but the other space is wired ? is something missing or would that be for a higher spec car ??
Chop78 is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  
Status: Misunderstood by many....
Temp Un-Registered
Join Date: Feb 2008
Location: South Wales
Posts: 28,471

Member car:

147 JTDm Ti

Good Morning, and Welcome to the A.O. Forum, I'm sure you will enjoy it here.........
n13roy is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome