166 ICS illumination problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 03-11-06 Thread Starter
Status: I'm back
AO Silver Member
 
Gramat's Avatar
 
Join Date: Sep 2006
Location: Macedonia
Posts: 1,422
Images: 46
Re: 166 ICS illumination problem

Welcome to AO
Gramat is offline  
Sponsored Links
Advertisement
 
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: 166 ICS illumination problem

welcome to AO dude.....


 
Status: -
Newbie
 
Join Date: Nov 2006
Location: Drogheda, Ireland
Posts: 4

Member car:

Alfa 166

166 ICS illumination problem

Hi

I have a 166 2001 2.0l THe car has been of f the road as I have a company vehicle. When I went to start it the battery was flat (no surprise there) but the ICS ssytem would not illuminate - although it works fine - I needed a torch to input the security code.

I have checked the fuses and they all seem OK.

I am going to try and remove the unit and check the connections although I have seen the posted woes on this task.

Any help would be welcome.

Thanks

uptown is offline  
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: 166 ICS illumination problem

Hi mate, welcome to the forum

It may be better to post this query in the Tech Lounge so to get better visibility from fellow 166 drivers!
BigFoot is offline  
Status: Spider's ready to go!
Global Mod Team
 
classicgal93's Avatar
 
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,019
Images: 2
Garage
Re: 166 ICS illumination problem

Hi and welcome, hope you get your problem fixed. Cheers
classicgal93 is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
166 , ics , illumination , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome