Hello - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 25-10-06 Thread Starter
Status: -
Newbie
 
Join Date: Oct 2006
Posts: 2

Member car:

Alfa 156 2.0 TS

Hello

Hi,

I have just joined this website after recently buying my first Alfa - a 1998 156 2.0TS. It is a great car to drive - has done 67k - CAM belt changed at 52k. I have just had it serviced.

It does however have a couple of problems - nothing too serious i hope. It sounds a bit like a diesel on start-up. Probably needs a new CAM variator - will it do my car any damage or can I wait to my next belt change to get it sorted?

It also has a poor idle - fluctuates from 500 to 1500-2000 when coming to a junction - also has some flat spots when accelerating from cold and below 3000RPM. The injector light is almonst always on too. I have replaced the MAF, cleaned the throttle body and all of the plugs were changed just before I bought the car a month ago. The next thing I am going to do is probably replace the lambda sensor - can anyone tell me how may there are on my car and can I do it myself?

If anyone can offer any suggestions or advice it would be very much appreciated.

Many thanks......
billfp156 is offline  
Sponsored Links
Advertisement
 
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: Hello

welcome to AO dude


 
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: Hello

I somehow have a feeling of deja vu...
BigFoot is offline  
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: Hello

Quote:
Originally Posted by BigFoot
I somehow have a feeling of deja vu...
you can get tablets for that


 
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: Hello

Quote:
Originally Posted by mikebrown
you can get tablets for that
Nah, I do like the feeling
BigFoot is offline  
Status: Spider's ready to go!
Global Mod Team
 
classicgal93's Avatar
 
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,013
Images: 2
Garage
Re: Hello

Hi and welcome to the site. Enjoy
classicgal93 is offline  
Status: I'm back
AO Silver Member
 
Gramat's Avatar
 
Join Date: Sep 2006
Location: Macedonia
Posts: 1,422
Images: 46
Re: Hello

Welcome to AO
Gramat is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

« Hi | Hello »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome