Help! Turn Key and nothing happens! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-10-06 Thread Starter
Status: -
Newbie
 
Join Date: Oct 2006
Posts: 3

Member car:

Alfa Romeo 147

Help! Turn Key and nothing happens!

I have an Alfa 147 T spark and when going back to my car after lunch today, I put the key in the ignition to start the car and nothing happened!? There was a clicking noise and now nothing. I cannot even lock the car...... The stereo works and the lights but that is it.

I have tried putting a new battery in the key but am completely clueless as what to do next?

Any ideas???
JamAlfa29 is offline  
Sponsored Links
Advertisement
 
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: Help! Turn Key and nothing happens!

sorry to hear of your problems dude...are you getting any lights on the dash ?


 
wrinx
Status: - Update
Guest
 
Posts: n/a
Re: Help! Turn Key and nothing happens!

Hasn't this been sorted...battery is the problem.

wrinx
 
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
key , turn

« New User | Hello, »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome