alfa virgin with connect+ satnav problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 06-10-06 Thread Starter
Status: -
Newbie
 
Join Date: Oct 2006
Location: London
Posts: 4

Member car:

147

Cry Like A Baby alfa virgin with connect+ satnav problem

Well that is to say... I am on my 5th alfa... a 147 having owned no other marque. It started as a student with a Alfasud Ti 1200, then the 1500 after which I built up a series 3 Alfasud Sprint. Then with less time on my hands... moved to a 145 Cloverleaf and now its the 147 5 door 2 litre Lusso. With a growing family, I would like to move to a 159 Sportwagon before to long... only problem is, I can't sell the 147 as the fancy Connect+ Satnav system has started to become faulty ie: the slot loading CD reader struggles to read the mapping data off the CD... very frustrating and now not under warranty!
willars is offline  
Sponsored Links
Advertisement
 
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: alfa virgin with connect+ satnav problem

welcome to AO dude...sorry to hear of your satnav problems..hopefully someone will be along soon to help you out


 
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: alfa virgin with connect+ satnav problem

Hi there, welcome to the forum

Quick question: is the CD in good shape? It may be simply a case of some damage to the CD ...
BigFoot is offline  
Status: -
AO Platinum Member
 
Gary Slegg's Avatar
 
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Re: alfa virgin with connect+ satnav problem

Hello and welcome
Gary Slegg is offline  
Status: Generating blue smoke. Lots of it!
Club Member
Membro Premio
 
Probusterrace's Avatar
 
Club Member Number: 25
Join Date: Jul 2006
Location: United Kingdom
County: Shropshire
Posts: 2,701
Images: 14
Re: alfa virgin with connect+ satnav problem

Welcome to AO.

Have you done a search of the forums? Fairly likely that someone on here has had the same problem!
Probusterrace is offline  
Status: Spider's ready to go!
Global Mod Team
 
classicgal93's Avatar
 
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,018
Images: 2
Garage
Re: alfa virgin with connect+ satnav problem

HI and welcome to this great site. Good luck with your problem.
classicgal93 is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
alfa , connect , problem , satnav , virgin

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome