Alfa 147 rear brake pads - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 02-10-06 Thread Starter
Status: -
Newbie
 
Join Date: Oct 2006
Posts: 7

Member car:

Alfa 147

Alfa 147 rear brake pads

Hi....I am hoping that someone can help me here ? I am changing the rear brake pads on my Alfa 147 for the first time and found the job pretty straight forward until it came to winding the piston back into the caliper (to give room for the new thicker pads). Something seems to be stopping it from winding back in.

Initial thoughts are (1) is there a bias valve preventing fluid returning out of the piston. (2) Should I have removed the hand brake cable?
(3) Is there something else that I should be doing that I am missing ?

Any help gratefully received
Andy
AndyFl is offline  
Sponsored Links
Advertisement
 
Status: -
AO Platinum Member
 
nomad's Avatar
 
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:

RRS TDV8 HSE

Wave Re: Alfa 147 rear brake pads

Hi Andy !!

Sorry to hear about your probs... post it up in the 147 area you'll probably get a better response there !!
nomad is offline  
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: Alfa 147 rear brake pads

welcome to AO dude


 
wrinx
Status: - Update
Guest
 
Posts: n/a
Re: Alfa 147 rear brake pads

Did you remove the brake fluid reservoir cap? Have you got a windback tool?

Helps to remove the handbrake as well as you have to reset it anyway.

wrinx
 
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
147 , alfa , brake , pads , rear

« New Member | Hello »
Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome