Hello - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 10 Old 20-09-06 Thread Starter
Status: -
Newbie
 
Join Date: Sep 2006
Posts: 7
Hello

Hi there
I'm a relatively new alfa romeo owner and for the past few weeks have been an extremely happy one. I have a 1999 alfa romeo 156 2.5 v6 which i use as a second car. this week i have started to have a few problems though. hope some one can help?
A light has come on on the dashboard on the speedo dial above the oil and battery lights. The car then drops to about 1000 rpm and will not rise any higher. eventually the car cuts out and will not start for about 15 minutes. I had the air flow unit replaced and there has been some injector cleaner through the system. Anyone any ideas??
paulrovers is offline  
Sponsored Links
Advertisement
 
Status: G7 JTS is back :D
AO Gold Member
 
Lynn GT's Avatar
 
Join Date: Oct 2005
Location: United Kingdom
County: -
Posts: 7,218
Images: 13
Re: Hello

Hi Paul, welcome to AO

(You may be better off posting your question in the techie lounge as it's likely to get picked up quicker.)
Lynn GT is offline  
Status: Spider's ready to go!
Global Mod Team
 
classicgal93's Avatar
 
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,013
Images: 2
Garage
Re: Hello

Hello and welcome to the site.
classicgal93 is offline  
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: Hello

Hi Paul, welcome on board

May I refer you to the Technical lounge for any specific query? You should get better visibility from AO members
BigFoot is offline  
Status: Standby.........
AO Platinum Member
 
mr.orange's Avatar
 
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:

156

Re: Hello

Hello and welcome
mr.orange is offline  
Status: -
AO Platinum Member
 
nomad's Avatar
 
Join Date: Aug 2006
County: -
Posts: 43,564
Images: 8

Member car:

RRS TDV8 HSE

Wave Re: Hello

Hello and welcome !!
nomad is offline  
(Post Link) post #7 of 10 Old 21-09-06 Thread Starter
Status: -
Newbie
 
Join Date: Sep 2006
Posts: 7
Re: Hello

thanks for everyones reply. I've had some good news today. the fault has been traced back to a faulty knock sensor which has been cutting fuel supply to the engine intermittently. Quick fix and back up and roaring along again.
paulrovers is offline  
Status: -
AO Member
 
TheFrenchTifosi's Avatar
 
Join Date: Aug 2006
Location: Leicestershire
Posts: 292
Images: 4
Re: Hello

Welcome on board Paul,

I hope that you will really appreciate the full expertise provided by very enthusiast Alfa lover here.

All the Best,

Fabrice
TheFrenchTifosi is offline  
Status: Generating blue smoke. Lots of it!
Club Member
Membro Premio
 
Probusterrace's Avatar
 
Club Member Number: 25
Join Date: Jul 2006
Location: United Kingdom
County: Shropshire
Posts: 2,701
Images: 14
Re: Hello

Greetings.

Good advice there from Lynnb and BigFoot.
Probusterrace is offline  
mikebrown
Status: - Update
Guest
 
Posts: n/a
Re: Hello

welcome to AO dude


 
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome