Introduction only - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 9 Old 26-01-14 Thread Starter
Status: -
Join Date: Jan 2014
Location: United Kingdom
County: Greater London
Posts: 2

Member car:


Introduction only

Dudley1 here. I have a 159 JTD 8 years old. It rides well of course but has the odd problem.
Dudley1 is offline  
Sponsored Links
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome
Durty dog is offline  
Status: Howling around Leicestershire
AO Silver Member
ferret-ears's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Leicestershire
Posts: 1,133
Images: 77
Hello and welcome
ferret-ears is offline  
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,695
Images: 20
Welcome to AO Dudley

If you want any advice, info or help check out the Tech Lounge Alfa 159, Brera & 946 Spider - Alfa Romeo Forum
David P is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Welcome to AO Dudley
BigFoot is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti

Hi :hi:

Welcome to AO
Greener123 is offline  
(Post Link) post #7 of 9 Old 27-01-14 Thread Starter
Status: -
Join Date: Jan 2014
Location: United Kingdom
County: Greater London
Posts: 2

Member car:


Thanks all. It appears my steering column control may have gone and all the electrics so that's why I had a slight problem starting! Tried all the usual and then had to get it towed to garage. Let you know what happens at great expense of course. Cheers Dudley1
Dudley1 is offline  
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Hi Dudley waving I hope it doesn't cost too much to fix!
classicgal93 is offline  
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Welcome To‵⁀) ✫ ✫ ✫.
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛° 。* °♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
SCGT is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome