Hi Everyone...Pls Help! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 11 Old 01-09-06 Thread Starter
Status: -
Newbie
 
Join Date: Sep 2006
Location: South Africa
Posts: 4
Well Happy Hi Everyone...Pls Help!

I joined up today & I own a 2005 black 156 2.4 JTD 20v Lusso. I love the caer to bits & the Alfa heritage runs through our family here in SA. I live in Johannesburg.

Since I got the car last November, I have had numerous problems that have broken my heart. The brakes were shabby & the front pads were changed twice by AR dealer citing a very hard compound. From day one the car had a severe torque steer problem & the left side shaft gave up after a month. The car sat at the AR Dealer from Feb this year till June awaiting parts. When I got the car back, the problem reared it's ugly head a week later. The car went back in. When it came out the right side shaft started having rotational/balance problems & the side shaft was subsequently replaced.

Due to Diesel usage here in SA only picking up after the new millenium, the Filling Stations were never very well equipped with Diesel but now after new legislation, they have to offer 500ppm low sulphur diesel. A week after receiving the car as stated at the end of the previous paragraph, a filling attendant filled my tank with about 20 litres of unleaded fuel, after me requesting diesel & this niceley spelt out on the fuel cap. The car was towed to AR & the tank drained out. I received the car about 3 days later.

From that day I felt the car had a lack of urge & that the car only started boosting after the 2000 rpm mark with a huge kick, making it very uncomfortable to drive in traffic. The fuel consumption has almost doubled since then & now the car feels very lethargic & she battles to boost, you don't feel the kick now & she just revs till about 3500 without any major change in the momentum when compared to before. I've taken it to the AR dealer who had the computer checked & all of the parameter settings were still fine. What I have also picked up is that there now is this terribly strong smell of diesel & she smokes in any gear, at any speed. As said the fuel consumption used to average about 5litres/100km, & about 4.3 with good driving. But now it's staggeringly high at between 8.3 & 9.2l/100km. The car is due back at the dealer on Tuesday & they said that they will strip the turbo & look at the hosing to see if all's ok.

Can any of you kind souls out there pls help me. Has anyone encountered any of the symptoms & has found known problems similar to mine?

Thanks...All of your assistance is much appreciated!!!
Niven24 is offline  
Sponsored Links
Advertisement
 
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: Hi Everyone...Pls Help!

Hi mate, welcome to the forum

Sorry to hear about the mishaps and am sure some of the lads will come along with some advice.
BigFoot is offline  
(Post Link) post #3 of 11 Old 01-09-06 Thread Starter
Status: -
Newbie
 
Join Date: Sep 2006
Location: South Africa
Posts: 4
Re: Hi Everyone...Pls Help!

Hey BigFoot,

Thanks...hoping for some good f/back.

Murano is cool, wife wants to change her Mazda 6 for a 350z convertible! And my previous car was an Infiniti G20T - very reliable car!
Niven24 is offline  
Status: The BSD says konnichiwa
Global Mod Team
 
BigFoot's Avatar
 
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Garage
Re: Hi Everyone...Pls Help!

The 350Z is a great car. Still, I'd get a Brera because it's just so beautiful.
BigFoot is offline  
(Post Link) post #5 of 11 Old 01-09-06 Thread Starter
Status: -
Newbie
 
Join Date: Sep 2006
Location: South Africa
Posts: 4
Re: Hi Everyone...Pls Help!

Our currency & the prices they come into the country make it favour the Z but had I the opp, would also go for the Brera or maybe the Spyder 3.2
Niven24 is offline  
Status: -
AO Platinum Member
 
Gary Slegg's Avatar
 
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Re: Hi Everyone...Pls Help!

Its well know that putting petrol in a diesel can cause damage to the engine as the diesel helps lubricate the engine (a quality petrol doesn't have), but if you didn't start the car up then that shouldn't be a problem...Welcome to the forum by the way
Gary Slegg is offline  
Status: making daily raids across the border
AO Gold Member
 
alfaholic's Avatar
 
Join Date: Aug 2001
Location: United Kingdom
County: Surrey
Posts: 6,451

Member car:

6C 2500

Re: Hi Everyone...Pls Help!

Welcome to AO
alfaholic is offline  
(Post Link) post #8 of 11 Old 01-09-06 Thread Starter
Status: -
Newbie
 
Join Date: Sep 2006
Location: South Africa
Posts: 4
Re: Hi Everyone...Pls Help!

Hey Alfaholic & Gary,

Thanks for the welcome btw.
Niven24 is offline  
Status: -
Newbie
 
Join Date: Jul 2006
Location: Kemnay, Scotland
Posts: 7
Re: Hi Everyone...Pls Help!

Welcome fellow newbie! And i thought my first few monthe with my alfa were bad!

But im still glad I bought it!
Super-squirrel is offline  
Status: Standby.........
AO Platinum Member
 
mr.orange's Avatar
 
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:

156

Re: Hi Everyone...Pls Help!

Hello and welcome
mr.orange is offline  
Status: -
AO Silver Member
 
Alfagirl's Avatar
 
Join Date: Apr 2005
Location: Finland
County: Etela-Suomen Laani
Posts: 2,576

Member car:

156 2,5 V6

Re: Hi Everyone...Pls Help!

Hello and welcome
Alfagirl is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
everyonepls

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome