Hello All - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 14 Old 29-12-13 Thread Starter
Status: Firing on all cylinders :)
AO Member
P3rksy's Avatar
Join Date: Dec 2013
Location: Cardiff, United Kingdom
County: Glamorgan
Posts: 228
Images: 10
Hello All

My name is Phil and I have recently retired at age 59.
I have bought my project to keep me busy... a 1999 GTV 3.0 6V 24V metallic red
It's got the usual common niggles to put right but overall it is in excellent condition.
I hope to see you all soon out on the roads of Cardiff and South Wales, or even further if I can afford the petrol
P3rksy is offline  
Sponsored Links
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome, pics please
Durty dog is offline  
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Welcome To‵⁀) ✫ ✫ ✫.
☻/ღ˚ •。* ♥♥ ˚ ˚✰˚ ˛★* 。 ღ˛ 。* ♥ ˚ • ★
/▌*˛˚ ░A░L░F░A░ - ░O░W░N░E░R░ ˚ ✰* ★
/ \ ˚. ★ *˛ ˚♥♥* ✰。˚ ˚ღ。* ˛˚ ♥♥ 。✰˚* ˚ ★
SCGT is offline  
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,612
Images: 19
Welcome to AO Phil & congrats on the GTV

Check out the Tech Lounge Alfa GTV & 916 Spider - Alfa Romeo Forum if you want any advice, info & help.
David P is offline  
Status: Howling around Leicestershire
AO Silver Member
ferret-ears's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Leicestershire
Posts: 1,133
Images: 77
Hello and welcome
ferret-ears is offline  
Status: Spider's ready to go!
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,043
Images: 2
Hi Phil waving congrats on retiring and your Alfa
classicgal93 is offline  
(Post Link) post #7 of 14 Old 30-12-13 Thread Starter
Status: Firing on all cylinders :)
AO Member
P3rksy's Avatar
Join Date: Dec 2013
Location: Cardiff, United Kingdom
County: Glamorgan
Posts: 228
Images: 10
Thanks for the welcome guys.

I have uploaded some images of the GTV in the just bought state ... awaiting the moderator to approve.
With the Christmas festivities and the weather being awful, rain and wind, I haven't had chance to do anything to it yet.

The first job I need to do is replace the two flexi pipes on the exhaust system before putting it on a diagnostic machine (my brother has a mate who owns one ). The car is under performing and I think the MAF might also need changing ... I will have to wait and see what the diagnostics show.

The passenger door window is not sealing correctly. I hope I get the adjustment right first time and not be there all day!

Then all it needs is a valet and a shine. The paintwork is in excellent condition with just a couple of minor swirl marks, nothing the DAS polisher won't sort out. I hope to get it back to better than showroom condition.

I tell a fib. The offside back bumper has been cracked and repaired (not very well but nothing Dents Away can't handle) by the one previous owner, a sixty six year old genuine guy who has told me everything about the car.

I will post more pics as I do the work.
P3rksy is offline  
Status: R.I.P Paula :(
AO Rosso Alfa Member
Shant Ole's Avatar
Join Date: Dec 2009
Location: Cyprus
County: Larnaca
Posts: 57,686
Hello and welcome
Shant Ole is offline  
Status: Hmmm....
Regional Representative
For South Central - AOSC
Greener123's Avatar
Join Date: Nov 2013
Location: Southampton
County: Hampshire
Posts: 39,396

Member car:

159 2.0 JTDM Ti


Welcome to AO

from a fellow Newbie
Greener123 is offline  
(Post Link) post #10 of 14 Old 05-01-14 Thread Starter
Status: Firing on all cylinders :)
AO Member
P3rksy's Avatar
Join Date: Dec 2013
Location: Cardiff, United Kingdom
County: Glamorgan
Posts: 228
Images: 10
Acceleration problem

Hi All

I've uploaded some images in my profile but can't see them yet ... moderator approval required?

I've therefore uploaded some others to my Dropbox account in the hope you can see them from there:
The flexi exhaust pipes were blown when I bought the car so I had to sort this out first before sorting an acceleration problem. I bit the bullet and replaced the whole system with a Longlife stainless steel system. Looks great and sounds terrific but the wife isn't happy... cost 550.
The acceleration problem in short is, if I rev hard when accelerating the engine will miss and sometimes stall, no matter what gear I am in. The car accelerates through the all the gears provided I don't rev too hard up to about 70/80 mph with no problem. If I then put my foot down the car will not accelerate any faster but start to miss and even stall ... dangerous if I'm in the outside lane. I have to pull over to the side of the road and switch off. Switch back on and away I go again. I haven't been on an open road yet to try and go any faster.
I have read the threads pointing to AFM, Air Intake, throttle potentiometer connections, etc; but with Christmas festivities and the horrible weather I haven't had the chance to work on it.

The Alfaaid specialist advice:
The throttle potentiometer if faulty at all creates an error so although it is a common fault on 1999/2000 cars I doubt that it is that. It could be another AFM as they are rubbish. Also make sure that the concertina ducting bit between the AFM and the throttle body is fitted correctly and that it is not split. If all that is ok then I would be suspecting coil packs or spark plugs.
I will let you all know when I'm on the road in earnest

P3rksy is offline  
Status: Have another Alfa
AO Gold Member
wayne-dear's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Merseyside
Posts: 10,132
Nice looking car that

When the engine hesitates is it throwing up any lights on the Dash, mine used to do it and a warning light would come on, turned out to be a dry joint in the throttle wiring, a quick jiggle would sort it.
wayne-dear is offline  
(Post Link) post #12 of 14 Old 10-01-14 Thread Starter
Status: Firing on all cylinders :)
AO Member
P3rksy's Avatar
Join Date: Dec 2013
Location: Cardiff, United Kingdom
County: Glamorgan
Posts: 228
Images: 10
Hi Wayne

Thanks for the comment. When I sort my acceleration problem out I shall move on to the detailing. I've got a DAS Polisher and the wife and kids bought me some more polish, glaze, sealant, and wax for Christmas ... can' wait to see it all gleaming

I'll take note of the throttle wiring. Diagnostics is not reporting any errors. I disconnected the AFM today and the car runs much better which points to it being duff. I shall give it a clean before investing in a new one as they are not cheap. I am not sure whether to replace it with a genuine or pattern.
The AFM was replaced in Nov 2009 with a genuine Bosch one by the Alfa Aid specialist whose words to me now are:

It could be another AFM as they are rubbish
Since the last AFM has lasted only three years, do I buy another genuine Bosch replacement or do I chance getting a pattern of eBay. I'm wary of the eBay replacement as the threads in the AO forum give negative feedback.

Advice from AO members please! If the consensus is for genuine, where at the moment is the best deal?
P3rksy is offline  
(Post Link) post #13 of 14 Old 19-01-14 Thread Starter
Status: Firing on all cylinders :)
AO Member
P3rksy's Avatar
Join Date: Dec 2013
Location: Cardiff, United Kingdom
County: Glamorgan
Posts: 228
Images: 10
Hi All

I've sorted my acceleration performance issue

The previous owner fitted the wrong air filter

Full report in my other thread:

P3rksy is offline  
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Well done!

And a belated welcome
BigFoot is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome