Hi Everyone - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-05-06 Thread Starter
Status: -
Newbie
 
Join Date: May 2006
Posts: 2

Member car:

147 Selespeed

Hi Everyone

Just bought a 2003 147 Selespeed (my first Alfa and I'm loving it)and found that the rear wiper and cigar lighter don't work. Is is something simple like a fuse or should I contact the garage that I bought it from?

Cheers
SJ147 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
phil155's Avatar
 
Join Date: Jul 2005
Location: half way up the A12
Posts: 5,093
Images: 24
Re: Hi Everyone

welcome to AO mate
did you get a warranty? if so take it back mate and give 'em what for
phil155 is offline  
Status: making daily raids across the border
AO Gold Member
 
alfaholic's Avatar
 
Join Date: Aug 2001
Location: United Kingdom
County: Surrey
Posts: 6,451

Member car:

6C 2500

Re: Hi Everyone

Hello
alfaholic is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome