Hi New member with a technical problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 02-05-06 Thread Starter
Status: -
Newbie
 
Join Date: May 2006
Posts: 2

Member car:

166

Hi New member with a technical problem

Hi Guys

I have owned my alfa 166 3.0 since December and like a muppet I left my ignition on all day on friday whilst I was visiting a friend, I manage to jump start it but it won't rev over 1,5k rpm I have charged the battery and tried resetting by disconnecting the battery then connecting it again. does anyone else know what the problem might be or how to fix it.

Cheers
Dave
maddog71 is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 4 Old 02-05-06 Thread Starter
Status: -
Newbie
 
Join Date: May 2006
Posts: 2

Member car:

166

Re: Hi New member with a technical problem

I have done a search and seems it may be in limp home mode so will try disconnecting battery
maddog71 is offline  
Status: -
AO Silver Member
 
rustyQV's Avatar
 
Join Date: Mar 2006
Posts: 1,058

Member car:

33 156 164

Re: Hi New member with a technical problem

Try leaving the battery disconnected for about half an hour....
rustyQV is offline  
Status: Bored with my reliable wrx
AO Silver Member
 
Bodgit's Avatar
 
Join Date: Jan 2006
Location: Near The Seashore
Posts: 1,077
Re: Hi New member with a technical problem

You`ll proberly have to take it in to the dreaded Alfa Dealership to plug it in to their finggey-ma-jiggy.Better go and see the Bank Manager first thou.lol
Bodgit is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
member , problem , technical

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome