Newbie - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
Holeshot
Status: - Update
Guest
 
Posts: n/a
Wave Newbie

Hi all, I,m currently running around in a mondeo diesel but it's time for a real car. Thought about going japanese but thought again. Always liked alfas for their styling and after having owned bmw's for 15 years (wife's still got her 318ci) and with my son's acquisition of a punto 1.2 16v sporting (what a hoot), italian it is.

Found loads of usefull info both here and other sites and have been looking at the 147 2.0, not decided manual or selespeed

Looked at a 147 selespeed the other day and the odometer was flashing which I understand to indicate a fault but not with the air bag , ABS or engine management, any ideas anyone?

Anyway hope to buy one soon and look forward to being part of AO
 
Sponsored Links
Advertisement
 
Status: Being of sound body
AO Platinum Member
 
73GTVJim's Avatar
 
Join Date: Mar 2006
Location: United Kingdom
County: Greater Manchester
Posts: 23,146
Images: 32
Garage
Re: Newbie

Hi Holeshot and welcome from another newbie.

You might notice a change in reliability and build quality from the BMW to be honest but you get other harder-to-quantify plusses from the Alfa.

Never driven a Selespeed but most reports seem generally negative so I'd swerve it for a manual.

Sorry I don't know about the warning light.

Enjoy your Alfa and the community - it's very welcoming from my short experience so far.
73GTVJim is offline  
jto
Status: -
AO Member
 
jto's Avatar
 
Join Date: Mar 2006
Location: Copenhagen
Posts: 10
Re: Newbie

Itís about time you got to your senses ! Get rid of the Mondeo! I have a brother who has the same disease in green!

I can recommend a 147! A grade Italian car with some few Italian issues (actually much better than my old Fiat Punto Sporting). Sometimes, when I start my car, my anti-spin and ABS light is showing an error for no reason, besides its Italian. It disappears when I turn it off and on again. I'm not familiar with the problem you are describing, but you are looking at the right car!
jto is offline  
Status: -
AO Silver Member
 
phil155's Avatar
 
Join Date: Jul 2005
Location: half way up the A12
Posts: 5,093
Images: 24
Re: Newbie

ELLO
phil155 is offline  
Status: making daily raids across the border
AO Gold Member
 
alfaholic's Avatar
 
Join Date: Aug 2001
Location: United Kingdom
County: Surrey
Posts: 6,451

Member car:

6C 2500

Re: Newbie

Welcome to AO

PS go manual
alfaholic is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
newbie

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome