Finally introducing myself (after nearly a year) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 26-01-06 Thread Starter
Status: 110,300 and Warm
AO Member
 
James76's Avatar
 
Join Date: Mar 2005
Location: United Kingdom
County: Scottish Borders
Posts: 607
Images: 6
Wave Finally introducing myself (after nearly a year)

Hi there y'all

Some of you may recall me from around last year when Korkycat intro'd himself and i just snuck in the back door, rude of me i know but as we have only just got broadband here (back end of nowhere just west of Berwick) couldn't really do much about it (3 mins for a thread page to load, ARRGGHH!).

Also i have finally stepped back into the light and own an Alfa again (the 155 v6 didn't make it - would have cost a shedload to put right, pity as it had only covered 55k) BUT new baby, a 156 JTS Lusso in silver is making me all smiley again. There is only so long you can take a Mondeo!

Will post a pic as soon as i can (when i find an operational camera)

Feel free to slag me off for taking this long
James76 is offline  
Sponsored Links
Advertisement
 
wrinx
Status: - Update
Guest
 
Posts: n/a
Re: Finally introducing myself (after nearly a year)

Welcome back

Hope the two hour gap for a response didn't make you feel like we were all ignoring you

Shame about the 155 V6, presume that means there's one less of the 500 or so in the UK? Mine is deciding it needs a bit more attention by splitting a gaitor and requiring the oil cooler sorting again...perhaps I should spend more time driving it!

Hope you stick around....

wrinx
 
Status: -
AO Silver Member
 
Trailbraker's Avatar
 
Join Date: Mar 2005
Location: Ireland
County: -
Posts: 5,179

Member car:

156 GTA

Re: Finally introducing myself (after nearly a year)

Does your Girlfriend ever say "Home James and don't spare the Horses" (on your 156 Lusso)

Welcome to AO
TB
Trailbraker is offline  
Status: -
Club Member
Membro Premio
 
Club Member Number: 1561
Join Date: Dec 2001
Location: Netherlands
County: -
Posts: 12,865
Images: 305

Member car:

busso powered

Re: Finally introducing myself (after nearly a year)

Welcome back. Sorry to hear the V6 didn't make it

Enjoy the 156 though
selespeed is offline  
Status: up to my eyeballs in work :-(
AO Gold Member
 
Green Cloverleaf's Avatar
 
Join Date: Jun 2004
Location: United Kingdom
County: Hampshire
Posts: 7,160
Images: 13
Re: Finally introducing myself (after nearly a year)

Welcome to AO

Don't forget to post some pics of your car
Green Cloverleaf is offline  
Status: 0.9 turbo power....
AO Silver Member
 
p17sut's Avatar
 
Join Date: Nov 2004
Location: United Kingdom
County: Fife
Posts: 3,221
Images: 33

Member car:

500 twinair

Re: Finally introducing myself (after nearly a year)

Welcome James
I remember the V6 mentioned last year, shame!
All the best with the 156, and welcome back!
p17sut is offline  
(Post Link) post #7 of 7 Old 27-01-06 Thread Starter
Status: 110,300 and Warm
AO Member
 
James76's Avatar
 
Join Date: Mar 2005
Location: United Kingdom
County: Scottish Borders
Posts: 607
Images: 6
Re: Finally introducing myself (after nearly a year)

Thanks for the welcome back guys

Was a pity the 155 didn't make it, it had been excellent until the breakdown that no one could figure It was a 1993 Narrowbody with full Lusso Spec (K82 SLU), it had everything a 155 could be fitted with. In Red too! (Can you tell i miss it?) It took 6 months to find that all that was wrong was a goosed crank sensor (voltage dropping instead of increasing on starting, it took 4 hrs for the actual repair!)

However lack of cash at the time led to me not being able to fix the issues arising for having stood as long - and when i eventually could it had gone too far. Was looking at a engine rebuild, new cambelt before i got to the running gear - i had run out of the ability to see it through.

Oh Yeah, it also did teh exploding oil cooler thing. Nice to know it wasn't only me Wrinx!

The 156 has resulted in me getting Acquired Alfa Disorder again though! Lovin It! I may need to do something about the 300+ miles a week i am doing at the mo though!

We have no plan, therefore nothing can go wrong (much)

And i Have finally put piccies of the silver one on!!
James76 is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
finally , introducing , year

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome