My first Alfa - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

 
Thread Tools Search this Thread
(Post Link) post #1 of 12 Old 16-11-05 Thread Starter
Status: -
AO Member
 
savannahsister's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Merseyside
Posts: 210
My first Alfa

Hi everyone I have just plucked up the courage to introduce myself, I have had my car for 4 months, and although I love it, I have had nothing but problems with it! It's a 156 2.4 JTD 20v (remapped), great to drive!
savannahsister is offline  
Sponsored Links
Advertisement
 
Status: making daily raids across the border
AO Gold Member
 
alfaholic's Avatar
 
Join Date: Aug 2001
Location: United Kingdom
County: Surrey
Posts: 6,451

Member car:

6C 2500

Re: My first Alfa

Welcome to AO.....any piccies of your bella?
alfaholic is offline  
Status: PSN ID: Jack155Q4
AO Gold Member
 
AlfaJack's Avatar
 
Join Date: May 2003
Location: United Kingdom
County: Kent
Posts: 6,822
Images: 4

Member car:

1993 Alfa 155 Q4

Re: My first Alfa

Welcome to AO Wouldnt mind a go in a remapped JTD oneday
AlfaJack is offline  
Status: 3.2 Busso powered
AO Gold Member
 
AlfaMartini's Avatar
 
Join Date: Sep 2005
Location: Abu Dhabi
Posts: 7,669
Re: My first Alfa

Hi Savannah - Welcome to the club.

My GTA is 4 months old now, and will be going in for its 1st service next month accompanied by a list of minor faults (mostly intermittant electrical gremlins). However I'm totally smitten and wouldn't trade it for any other car

AM
AlfaMartini is offline  
145qv
Status: - Update
Guest
 
Posts: n/a
Re: My first Alfa

Welcome to AO, both of you & yes do post some piccies.

There are lots of knowledgeable people on this forum that should be able to give pointers on what to do about yor problems
 
Status: Housebuilder, slowly.
AO Silver Member
 
Join Date: Aug 2004
Location: United Kingdom
County: Anglesey
Posts: 1,577
Re: My first Alfa

Yep, whether you are able to fix the faults yourself or not, it's good to know what the problems are, or just good to share them.

Welcome!

Buck
Buck Bundy is offline  
Status: Standby.........
AO Platinum Member
 
mr.orange's Avatar
 
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:

156

Re: My first Alfa

Hello and welcome to AO...
mr.orange is offline  
Status: -
AO Silver Member
 
Alfagirl's Avatar
 
Join Date: Apr 2005
Location: Finland
County: Etela-Suomen Laani
Posts: 2,576

Member car:

156 2,5 V6

Re: My first Alfa

Welcome to AO
Alfagirl is offline  
(Post Link) post #9 of 12 Old 17-11-05 Thread Starter
Status: -
AO Member
 
savannahsister's Avatar
 
Join Date: Aug 2005
Location: United Kingdom
County: Merseyside
Posts: 210
Re: My first Alfa

Thanks everyone. The major fault I found on my Alfa within a few weeks of owning it was the 'motor control failure' - after testing it was found to need a new turbo! After a lot of messing (weeks and weeks of it) and a forced meeting, the dealer managed to get a new turbo and fitted it this week. Seems that it may be a design fault and the manufacturer of the turbos has had to redesign it. Anyway, to cut a long story short its back on the road now, will have to get some pics soon, its in Alfa red and the dealer has polished it for me, so it looks great. They gave me a GT to ride in for the last week (to keep me happy) it looked the business but it was a little slow, lol! (1.9JTD)

Also, the airbag light has come on a couple of times and it needed a new fuel gauge sender, all this in a car that's not 18mths old yet!

I have had a look around the forum and I think that it's great that you share all your problems! Bye for now
savannahsister is offline  
Status: -
AO Platinum Member
 
Roswell's Avatar
 
Join Date: Mar 2004
Location: United Kingdom
County: Durham
Posts: 33,630
Images: 15
Re: My first Alfa

Hi Savannahsister. Welcome to AO.
Roswell is offline  
Status: frenzied burrowing
AO Platinum Member
 
Fraser's Avatar
 
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Images: 8
Re: My first Alfa

Welcome aboard Savannahsister.

I've got the same model (not mapped) and it's been trouble free so far (16 months and 19,000 miles). Hope all your troubles are sorted soon.
Fraser is offline  
Status: Housebuilder, slowly.
AO Silver Member
 
Join Date: Aug 2004
Location: United Kingdom
County: Anglesey
Posts: 1,577
Re: My first Alfa

Mmm, lets hope that's the last of your problems.
Buck Bundy is offline  
Reply

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

Tags
alfa

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome