Power draw on my 91 Alfa Spider - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-11-12 Thread Starter
Status: -
Join Date: Nov 2012
Location: United States
County: California
Posts: 1

Member car:

91 Alfa Spider

Power draw on my 91 Alfa Spider

Please help!! I have a 91 Alfa Spider Veloce. It is in extremely good condition and runs well, but has developed a draw on the battery. Every few days the battery is dead and the car won't start. The battery is new. I also tested every fuse with a multimeter hooked up and found no significant draw. Is there a common problem that shows up in these cars that could be drawing power off of my battery? The car used to start right up even after a week or more of not being driven. Any help would be appreciated.


Alfus91 is offline  
Sponsored Links
Status: Constantly Nagging Lincolnshire Members !
Regional Support
For Lincolnshire - AOL
Nige005's Avatar
Join Date: Jan 2008
Location: Boston, Lincs
Posts: 16,083
Images: 22
Put a Post in the Classic Lounge, you'll get help there.

The Classic Alfa Romeos - Alfa Romeo Forum
Nige005 is offline  
Status: R.I.P Paula :(
AO Rosso Alfa Member
Shant Ole's Avatar
Join Date: Dec 2009
Location: Cyprus
County: Larnaca
Posts: 57,686
What Nige said ^^^

Welcome to AO
Shant Ole is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

alfa , draw , power , spider

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome