166 light problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-11-12 Thread Starter
Status: -
Join Date: Nov 2012
Location: United Kingdom
County: Aberdeenshire
Posts: 2
Help 166 light problem

Hi all, my first query; i have a 2001 166 3.0 V6 super manual and very happy with it. now my rear lights and the number plate lights are not working. checked in the handbook for the fuse details and, guess what, the only fuse details i cannot find are for these lights i would have thought they were not all on one fuse anyway. checked the bulbs they are ok, anyone have any ideas please? just checked front sidelights out also...thanks, mike

Last edited by michaelandrews; 11-11-12 at 11:48.
michaelandrews is offline  
Sponsored Links
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,687
Images: 20
Welcome to AO

I'm sure someone in the Tech Lounge Alfa 164 & 166 - Alfa Romeo Forum will be able to help you
David P is offline  
Status: R.I.P Paula :(
AO Rosso Alfa Member
Shant Ole's Avatar
Join Date: Dec 2009
Location: Cyprus
County: Larnaca
Posts: 57,686
Hi and welcome to AO

Never experianced the same problem on my dads 166

Someone in the tech lounge might be able to help you as DP said
Shant Ole is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

166 , light , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome