OVERHEATING issues on my 156... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-09-12 Thread Starter
Status: -
Join Date: Sep 2012
Location: United Arab Emirates
County: Dubayy
Posts: 1

Member car:

alfa romeo 156

OVERHEATING issues on my 156...

Hi All, could somebody help me on how to fix the issues of overheating on my alfa 156, 98 model. It started when i upgrade the engine fro 2.5 to 3.0. it is reaching 110 degree after running the engine for at least 40-45 minutes.. would really appreciate the feedback pls.
henry suarez is offline  
Sponsored Links
Status: Spider's away for winter
Global Mod Team
classicgal93's Avatar
Join Date: Sep 2006
Location: Canada
County: British Columbia
Posts: 59,057
Images: 2
Hi Henry waving welcome to AO. Have a look in our tech sections for more help
classicgal93 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , issues , overheating

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome