Alfa Romeo 156 2.0 JTS -04 Motor issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-07-12 Thread Starter
Status: -
Join Date: Jul 2012
Location: Sweden
County: Örebro
Posts: 3
Alfa Romeo 156 2.0 JTS -04 Motor issue

I purchased this car a few days ago, the seller said it worked like a clock.

After driving a few miles a message appeared, "Motor controll Failure, go to dealer" or something. I went to a shop and they read with the computer these codes:

P0300 - Ignition Failures (generic)
P0303 - Cyl. 3 ignition failures
P1175 - Mixture 2 strength (multiplicative)
P0420 - Catalyser 1
P1176 - Mixture 2 strenght (additive)

I am by no means any car expert. The mechanic said it was running badly on low speed, and that someone had put tape on the tube for the air inlet.

The mechanic has so much to do, so he can't check the car properly until two weeks.

Does anyone have any idea if this could be expensive and what could be wrong with car.
Perrran is offline  
Sponsored Links
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Hi and welcome, try this section.

Alfa 147, 156 & GT - Alfa Romeo Forum
Durty dog is offline  
Status: Pain in the veins, but passion in the blood
AO Silver Member
giordano92's Avatar
Join Date: Oct 2009
Location: Australia
County: New South Wales
Posts: 4,378
Images: 10
Welcome to AO

Saluti, Giordano.
giordano92 is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself

156 , alfa , issue , jts , motor , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome