hi from Wales - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Introduce Yourself Again... No technical questions in here

Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-07-12 Thread Starter
Status: -
AO Member
Join Date: Jul 2012
Location: United Kingdom
County: Ceredigion
Posts: 20

Member car:

147 jtd lusso

hi from Wales

Hi all, I'm a proud owner of my late dad's 147 jtd Lusso, what a magic car. Never really been into cars before but this has really given me the bug. It's not just the fact that it was (although it seems that it still IS) dad's car but it drives and corners so well. My previous cars were all bangers compared to this. There are a couple of things that need fixing so I'll be pestering you all for advice! There's knocking coming from n/s front (roll bar/link?) and she was cutting out after 2/3 secs so disconnected the EGRvalve and she runs fine but obviously that'll need fixing before MOT. But I am a very proud owner and want to keep her in tip-top nic.
rainydayz is offline  
Sponsored Links
Status: Lowered!!
AO Rosso Alfa Member
Durty dog's Avatar
Join Date: Feb 2009
Location: Northampton
County: Northamptonshire
Posts: 73,506
Images: 18
Durty dog is offline  

Go Back   Alfa Romeo Forum > The Alfaowner Experience > Newbie Area > Introduce Yourself


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome